Exposure of sensitive information in Action Pack
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- High
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.
Summary
Action Pack is a framework for handling and responding to web requests. Under certain circumstances response bodies will not be closed. In the event a response is *not* notified of a `close`, `ActionDispatch::Executor` will not know to reset thread local state for the next request. This can lead to data being leaked to subsequent requests.This has been fixed in Rails 7.0.2.1, 6.1.4.5, 6.0.4.5, and 5.2.6.1. Upgrading is highly recommended, but to work around this problem a middleware described in GHSA-wh98-p28r-vrc9 can be used.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Rails | rails | 7.0.0.0 to before 7.0.2.1; 6.1.0.0 to before 6.1.4.5; 6.0.0.0 to before 6.0.4.5; 5.0.0 to before 5.2.6.1 | 7.0.2.1, 6.1.4.5, 6.0.4.5, 5.2.6.1 | Patch available | CNA |
| — | actionpack (RubyGems) | 5.0.0.0 to before 5.2.6.2 | 5.2.6.2 | Patch available | GHSA-wh98-p28r-vrc9 |
| — | actionpack (RubyGems) | 6.0.0.0 to before 6.0.4.6 | 6.0.4.6 | Patch available | GHSA-wh98-p28r-vrc9 |
| — | actionpack (RubyGems) | 6.1.0.0 to before 6.1.4.6 | 6.1.4.6 | Patch available | GHSA-wh98-p28r-vrc9 |
| — | actionpack (RubyGems) | 7.0.0.0 to before 7.0.2.2 | 7.0.2.2 | Patch available | GHSA-wh98-p28r-vrc9 |
- rails VendorRails Affected 7.0.0.0 to before 7.0.2.1; 6.1.0.0 to before 6.1.4.5; 6.0.0.0 to before 6.0.4.5; 5.0.0 to before 5.2.6.1 Fixed in 7.0.2.1, 6.1.4.5, 6.0.4.5, 5.2.6.1 Patch available CNA
- actionpack (RubyGems) Vendor— Affected 5.0.0.0 to before 5.2.6.2 Fixed in 5.2.6.2 Patch available GHSA-wh98-p28r-vrc9
- actionpack (RubyGems) Vendor— Affected 6.0.0.0 to before 6.0.4.6 Fixed in 6.0.4.6 Patch available GHSA-wh98-p28r-vrc9
- actionpack (RubyGems) Vendor— Affected 6.1.0.0 to before 6.1.4.6 Fixed in 6.1.4.6 Patch available GHSA-wh98-p28r-vrc9
- actionpack (RubyGems) Vendor— Affected 7.0.0.0 to before 7.0.2.2 Fixed in 7.0.2.2 Patch available GHSA-wh98-p28r-vrc9
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* | 5.0.0 to before 5.2.6.2; 6.0.0 to before 6.0.4.6; 6.1.0 to before 6.1.4.6; 7.0.0 to before 7.0.2.2 | Vulnerable | Rails |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.2.6.2; 6.0.0 to before 6.0.4.6; 6.1.0 to before 6.1.4.6; 7.0.0 to before 7.0.2.2 Vulnerable ·Rails
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA rails (rails) Fixed in 7.0.2.1, 6.1.4.5, 6.0.4.5, 5.2.6.1
- Fix · GHSA-wh98-p28r-vrc9 actionpack (RubyGems) Fixed in 5.2.6.2 Advisory →
- Fix · GHSA-wh98-p28r-vrc9 actionpack (RubyGems) Fixed in 6.0.4.6 Advisory →
- Fix · GHSA-wh98-p28r-vrc9 actionpack (RubyGems) Fixed in 6.1.4.6 Advisory →
- Fix · GHSA-wh98-p28r-vrc9 actionpack (RubyGems) Fixed in 7.0.2.2 Advisory →
Red Hat 1 advisory
- RHSA-2022:5498 Released 2022-07-05 · Red Hat rating ModerateSatellite 6.11 Release
- Red Hat Satellite 6.11 for RHEL 7 candlepin-4.1.13-1.el7sat, foreman-3.1.1.21-2.el7sat, libsolv-0.7.22-1.el7pc +4
- Red Hat Satellite 6.11 for RHEL 8 candlepin-4.1.13-1.el8sat, foreman-3.1.1.21-2.el8sat, libsolv-0.7.22-1.el8pc +8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6.11 for RHEL 7 | Fixed | RHSA-2022:5498 |
| Red Hat Satellite 6.11 for RHEL 8 | Fixed | RHSA-2022:5498 |
Not affected: 2 products
- Red Hat Satellite 6.11 for RHEL 7
- Red Hat Satellite 6.11 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23633
- 2026-10-03 Alias added: GHSA-wh98-p28r-vrc9
References
Patch 2
Advisory 4
Other 7
- https://security.netapp.com/advisory/ntap-20240119-0013/
- https://discuss.rubyonrails.org/t/cve-2022-23633-possible-exposure-of-information-vulnerability-in-action-pack/80016
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionpack/CVE-2022-23633.yml
- https://groups.google.com/g/ruby-security-ann/c/FkTM-_7zSNA/m/K2RiMJBlBAAJ
- https://rubyonrails.org/2022/2/11/Rails-7-0-2-2-6-1-4-6-6-0-4-6-and-5-2-6-2-have-been-released
- https://security.netapp.com/advisory/ntap-20240119-0013
More Rails vulnerabilities
- TI-2014-00124 Directory traversal vulnerability in actionpack/lib/abstract_controller/base.rb in the… KEVCVSS 3.1HIGH 7.5
- TI-2019-03828 Path traversal in Rails https://github.com/rails/rails KEVCVSS 3.1HIGH 7.5
- TI-2016-00672 Directory traversal vulnerability in Action View in Ruby on Rails before 3.2.22.1, 4.0.x… KEVCVSS 3.1HIGH 7.5
- TI-2019-03830 Command injection in Rails https://github.com/rails/rails CVSS 3.1CRITICAL 9.8
- TI-2020-06581 Code injection in https://github.com/rails/rails CVSS 3.1HIGH 8.8
- TI-2013-00091 active_support/core_ext/hash/conversions.rb in Ruby on Rails before 2.3.15, 3.0.x before… CVSS 2.0HIGH 7.5
Sources
- CVE-2022-23633 · CVE Program
- CVE-2022-23633 · NVD
- FIRST EPSS
- GHSA-wh98-p28r-vrc9 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23633 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences