Information Exposure when using Puma with Rails
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Information disclosure, Denial of service
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · CNA. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200 and CWE-404.
Summary
Puma is a Ruby/Rack web server built for parallelism. Prior to `puma` version `5.6.2`, `puma` may not always call `close` on the response body. Rails, prior to version `7.0.2.2`, depended on the response body being closed in order for its `CurrentAttributes` implementation to work correctly. The combination of these two behaviors (Puma not closing the body + Rails' Executor implementation) causes information leakage. This problem is fixed in Puma versions 5.6.2 and 4.3.11. This problem is fixed in Rails versions 7.02.2, 6.1.4.6, 6.0.4.6, and 5.2.6.2. Upgrading to a patched Rails _or_ Puma version fixes the vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| puma | puma | 5.0.0 to before 5.6.2; before 4.3.11 | 5.6.2, 4.3.11 | Patch available | CNA |
| — | puma (RubyGems) | 5.0.0 to before 5.6.2 | 5.6.2 | Patch available | GHSA-rmj8-8hhh-gv5h |
| — | puma (RubyGems) | before 4.3.11 | 4.3.11 | Patch available | GHSA-rmj8-8hhh-gv5h |
- puma Vendorpuma Affected 5.0.0 to before 5.6.2; before 4.3.11 Fixed in 5.6.2, 4.3.11 Patch available CNA
- puma (RubyGems) Vendor— Affected 5.0.0 to before 5.6.2 Fixed in 5.6.2 Patch available GHSA-rmj8-8hhh-gv5h
- puma (RubyGems) Vendor— Affected before 4.3.11 Fixed in 4.3.11 Patch available GHSA-rmj8-8hhh-gv5h
CPE configurations NVD · 8
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:puma:puma:*:*:*:*:*:ruby:*:* | before 4.3.11; 5.0.0 to before 5.6.2 | Vulnerable | puma |
| cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* | 5.0.0 to before 5.2.6.2; 6.0.0 to before 6.0.4.6; 6.1.0 to before 6.1.4.6; 7.0.0 to before 7.0.2.2 | Vulnerable | Rails |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
- cpe:2.3:a:puma:puma:*:*:*:*:*:ruby:*:* Versions before 4.3.11; 5.0.0 to before 5.6.2 Vulnerable ·puma
- cpe:2.3:a:rubyonrails:rails:*:*:*:*:*:*:*:* Versions 5.0.0 to before 5.2.6.2; 6.0.0 to before 6.0.4.6; 6.1.0 to before 6.1.4.6; 7.0.0 to before 7.0.2.2 Vulnerable ·Rails
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA puma (puma) Fixed in 5.6.2, 4.3.11
- Fix · GHSA-rmj8-8hhh-gv5h puma (RubyGems) Fixed in 5.6.2 Advisory →
- Fix · GHSA-rmj8-8hhh-gv5h puma (RubyGems) Fixed in 4.3.11 Advisory →
Red Hat 1 advisory
- RHSA-2022:5498 Released 2022-07-05 · Red Hat rating ModerateSatellite 6.11 Release
- Red Hat Satellite 6.11 for RHEL 7 candlepin-4.1.13-1.el7sat, foreman-3.1.1.21-2.el7sat, libsolv-0.7.22-1.el7pc +4
- Red Hat Satellite 6.11 for RHEL 8 candlepin-4.1.13-1.el8sat, foreman-3.1.1.21-2.el8sat, libsolv-0.7.22-1.el8pc +8
Vendor assessments
Red Hat
Red Hat rating: Important. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6 | Affected | No fix yet |
| Red Hat Satellite 6.11 for RHEL 7 | Fixed | RHSA-2022:5498 |
| Red Hat Satellite 6.11 for RHEL 8 | Fixed | RHSA-2022:5498 |
Not affected: 3 products
- Red Hat Satellite 6.11 for RHEL 7
- Red Hat Satellite 6.11 for RHEL 8
- Red Hat Storage 3
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23634
- 2026-10-03 Alias added: GHSA-rmj8-8hhh-gv5h
References
Patch 3
Advisory 10
- https://github.com/advisories/GHSA-rmj8-8hhh-gv5h
- https://github.com/advisories/GHSA-wh98-p28r-vrc9
- DSA-5146
- [debian-lts-announce] 20220525 [SECURITY] [DLA 3023-1] puma security update
- GLSA-202208-28
- [debian-lts-announce] 20220827 [SECURITY] [DLA 3083-1] puma security update
- FEDORA-2022-de968d1b6c
- FEDORA-2022-52d0032596
- FEDORA-2022-7c8b29195f
- https://nvd.nist.gov/vuln/detail/CVE-2022-23634
Other 5
- https://github.com/puma/puma
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/puma/CVE-2022-23634.yml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/F6YWGIIKL7KKTS3ZOAYMYPC7D6WQ5OA5
- https://lists.fedoraproject.org/archives/list/[email protected]/message/L7NESIBFCNSR3XH7LXDPKVMSUBNUB43G
- https://lists.fedoraproject.org/archives/list/[email protected]/message/TUBFJ44NCKJ34LECZRAP4N5VL6USJSIB
More Puma vulnerabilities
- TI-2022-08603 HTTP Request Smuggling in puma CVSS 3.1CRITICAL 9.1
- TI-2023-21048 Inconsistent Interpretation of HTTP Requests in puma CVSS 3.1CRITICAL 9.8
- TI-2020-08950 HTTP Smuggling via Transfer-Encoding Header in Puma CVSS 3.1HIGH 7.5
- TI-2020-08951 HTTP Smuggling via Transfer-Encoding Header in Puma CVSS 3.1HIGH 7.5
- TI-2020-04303 HTTP Response Splitting in Puma CVSS 3.1HIGH 7.5
- TI-2019-12551 Potential DOS attack in Puma CVSS 3.1HIGH 7.5
Sources
- CVE-2022-23634 · CVE Program
- CVE-2022-23634 · NVD
- FIRST EPSS
- GHSA-rmj8-8hhh-gv5h · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23634 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences