In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days…
Priority MEDIUM 41CWE-770Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-770.
Summary
In api.rb in Sidekiq before 5.2.10 and 6.4.0, there is no limit on the number of days when requesting stats for the graph. This overloads the system, affecting the Web UI, and makes it unavailable to users.
Why it matters now
EPSS 0.05215 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial sidekiq (RubyGems): 6.4.0, 5.2.10Red Hat: 1 advisoryRed Hat: 2 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | sidekiq (RubyGems) | 6.0.0 to before 6.4.0 | 6.4.0 | Patch available | GHSA-jrfj-98qg-qjgv |
| — | sidekiq (RubyGems) | before 5.2.10 | 5.2.10 | Patch available | GHSA-jrfj-98qg-qjgv |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- sidekiq (RubyGems) Vendor— Affected 6.0.0 to before 6.4.0 Fixed in 6.4.0 Patch available GHSA-jrfj-98qg-qjgv
- sidekiq (RubyGems) Vendor— Affected before 5.2.10 Fixed in 5.2.10 Patch available GHSA-jrfj-98qg-qjgv
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:contribsys:sidekiq:*:*:*:*:*:*:*:* | before 5.2.10; 6.0.0 to before 6.4.0 | Vulnerable | contribsys |
| cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* | 9.0 | Vulnerable | Debian |
- cpe:2.3:a:contribsys:sidekiq:*:*:*:*:*:*:*:* Versions before 5.2.10; 6.0.0 to before 6.4.0 Vulnerable ·contribsys
- cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
Remediation
- Fix · GHSA-jrfj-98qg-qjgv sidekiq (RubyGems) Fixed in 6.4.0 Advisory →
- Fix · GHSA-jrfj-98qg-qjgv sidekiq (RubyGems) Fixed in 5.2.10 Advisory →
Red Hat 1 advisory
- RHSA-2022:5498 Released 2022-07-05 · Red Hat rating ModerateSatellite 6.11 Release
- Red Hat Satellite 6.11 for RHEL 7 candlepin-4.1.13-1.el7sat, foreman-3.1.1.21-2.el7sat, libsolv-0.7.22-1.el7pc +4
- Red Hat Satellite 6.11 for RHEL 8 candlepin-4.1.13-1.el8sat, foreman-3.1.1.21-2.el8sat, libsolv-0.7.22-1.el8pc +8
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.11 for RHEL 7 | Fixed | RHSA-2022:5498 |
| Red Hat Satellite 6.11 for RHEL 8 | Fixed | RHSA-2022:5498 |
Not affected: 2 products
- Red Hat Satellite 6.11 for RHEL 7
- Red Hat Satellite 6.11 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-23837
- 2026-10-03 Alias added: GHSA-jrfj-98qg-qjgv
References
Patch 2
Advisory 2
Sources
- CVE-2022-23837 · CVE Program
- CVE-2022-23837 · NVD
- FIRST EPSS
- GHSA-jrfj-98qg-qjgv · GitHub Advisory Database · CC BY 4.0
- CVE-2022-23837 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences