Whale browser before 3.12.129.18 allowed extensions to replace JavaScript files of the…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-552.
Summary
Whale browser before 3.12.129.18 allowed extensions to replace JavaScript files of the HWP viewer website which could access to local HWP files. When the HWP files were opened, the replaced script could read the files.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
Remediation
- Fix · CNA NAVER Whale browser (NAVER) Fixed in 3.12.129.46
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
NAVER Whale browser 3.12.129.46
4 records Highest priority Priority MEDIUM 1 MEDIUM, 3 LOW
Other records, highest priority first
- TI-2022-08030 Exposure of resource to wrong sphere in NAVER Whale browserPriority MEDIUM 44
- TI-2022-08029 The Web Request API in Whale browser before 3.12.129.18 allowed to deny access to the…Priority LOW 32
- TI-2022-08028 Improper privilege management in NAVER Whale browserPriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24075
- 2026-10-03 Alias added: GHSA-4rvm-66vq-v2f2
References
More NAVER vulnerabilities
- TI-2026-84161 billboard.js allows XSS via unsanitized series ids in legend templates CVSS 3.1MEDIUM 6.1
- TI-2026-19139 Server-side request forgery in NAVER lucy-xss-filter CVSS 3.1MEDIUM 6.1
- TI-2024-18782 Missing authorization in NAVER nGrinder CVSS 3.1MEDIUM 5.4
- TI-2025-31281 Prototype pollution in NAVER billboard.js CVSS 3.1CRITICAL 9.8
- TI-2024-18778 Deserialization of untrusted data in NAVER nGrinder CVSS 3.1CRITICAL 9.8
- TI-2024-18777 Deserialization of untrusted data in NAVER nGrinder CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-24075 · CVE Program
- CVE-2022-24075 · NVD
- FIRST EPSS
- GHSA-4rvm-66vq-v2f2 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences