Adobe Commerce checkout improper input validation leads to remote code execution
Priority CRITICAL 100Exploited in the wildCWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Adobe Commerce versions 2.4.3-p1 (and earlier) and 2.3.7-p2 (and earlier) are affected by an improper input validation vulnerability during the checkout process. Exploitation of this issue does not require user interaction and could result in arbitrary code execution.
Why it matters now
Exploitation Active In CISA KEV since 2022-02-15CISA due date 2022-03-01
EPSS 0.99199 99th percentileScored 2026-11-07
Fix Fixed magento/community-edition (Packagist): 2.3.7-p3, 2.4.3-p2
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Active
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adobe | Magento Commerce | up to 2.4.3-p1; up to 2.3.7-p2; up to None | — | No fix listed | CNA |
| — | magento/community-edition (Packagist) | 2.3.3-p1 to before 2.3.7-p3 | 2.3.7-p3 | Patch available | GHSA-f8fv-f786-9933 |
| — | magento/community-edition (Packagist) | 2.4.0 to before 2.4.3-p2 | 2.4.3-p2 | Patch available | GHSA-f8fv-f786-9933 |
- Magento Commerce VendorAdobe Affected up to 2.4.3-p1; up to 2.3.7-p2; up to None Fixed in — No fix listed CNA
- magento/community-edition (Packagist) Vendor— Affected 2.3.3-p1 to before 2.3.7-p3 Fixed in 2.3.7-p3 Patch available GHSA-f8fv-f786-9933
- magento/community-edition (Packagist) Vendor— Affected 2.4.0 to before 2.4.3-p2 Fixed in 2.4.3-p2 Patch available GHSA-f8fv-f786-9933
CPE configurations NVD · 10
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* | before 2.3.0; 2.3.3 – 2.3.6; 2.4.0 – 2.4.2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:* | 2.3.7 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.3.7:p2:*:*:*:*:*:* | 2.3.7 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.3:-:*:*:*:*:*:* | 2.4.3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:commerce:2.4.3:p1:*:*:*:*:*:* | 2.4.3 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento:*:*:*:*:open_source:*:*:* | before 2.3.0; after 2.3.3, up to 2.3.6; 2.4.0 – 2.4.2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento:2.3.7:p1:*:*:open_source:*:*:* | 2.3.7 p1 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento:2.3.7:p2:*:*:open_source:*:*:* | 2.3.7 p2 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento:2.4.3:-:*:*:open_source:*:*:* | 2.4.3 | Vulnerable | Adobe |
| cpe:2.3:a:adobe:magento:2.4.3:p1:*:*:open_source:*:*:* | 2.4.3 p1 | Vulnerable | Adobe |
- cpe:2.3:a:adobe:commerce:*:*:*:*:*:*:*:* Versions before 2.3.0; 2.3.3 – 2.3.6; 2.4.0 – 2.4.2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.3.7:p1:*:*:*:*:*:* Versions 2.3.7 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.3.7:p2:*:*:*:*:*:* Versions 2.3.7 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.3:-:*:*:*:*:*:* Versions 2.4.3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:commerce:2.4.3:p1:*:*:*:*:*:* Versions 2.4.3 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento:*:*:*:*:open_source:*:*:* Versions before 2.3.0; after 2.3.3, up to 2.3.6; 2.4.0 – 2.4.2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento:2.3.7:p1:*:*:open_source:*:*:* Versions 2.3.7 p1 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento:2.3.7:p2:*:*:open_source:*:*:* Versions 2.3.7 p2 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento:2.4.3:-:*:*:open_source:*:*:* Versions 2.4.3 Vulnerable ·Adobe
- cpe:2.3:a:adobe:magento:2.4.3:p1:*:*:open_source:*:*:* Versions 2.4.3 p1 Vulnerable ·Adobe
Remediation
- Fix · GHSA-f8fv-f786-9933 magento/community-edition (Packagist) Fixed in 2.3.7-p3 Advisory →
- Fix · GHSA-f8fv-f786-9933 magento/community-edition (Packagist) Fixed in 2.4.3-p2 Advisory →
Timeline
- 2022-02-15 Added to CISA KEV
- 2026-10-02 Threatist record created from CVE-2022-24086
- 2026-10-03 Alias added: GHSA-f8fv-f786-9933
References
More Adobe Commerce vulnerabilities
- TI-2026-52938 Adobe Commerce | Improper Neutralization of Special Elements Used in a Template Engine (CWE-1336) KEVCVSS 3.1CRITICAL 10.0
- TI-2024-22559 XXE can expose crypt key and other secrets granting full admin access KEVCVSS 3.1CRITICAL 9.8
- TI-2026-35762 Unrestricted file upload in Adobe Commerce allows code execution KEVCVSS 3.1CRITICAL 9.3
- TI-2026-50010 Adobe Commerce | Incorrect Authorization (CWE-863) KEVCVSS 3.1CRITICAL 9.1
- TI-2025-34067 Adobe Commerce | Improper Input Validation (CWE-20) KEVCVSS 3.1CRITICAL 9.1
- TI-2025-18169 Adobe Commerce | Incorrect Authorization (CWE-863) CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-24086 · CVE Program
- CVE-2022-24086 · NVD
- CISA Known Exploited Vulnerabilities
- FIRST EPSS
- GHSA-f8fv-f786-9933 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences