In JetBrains Kotlin before 1.6.0, it was not possible to lock dependencies for Multiplatform Gradle Projects.
Priority LOW 28CWE-829Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-829.
Summary
In JetBrains Kotlin before 1.6.0, it was not possible to lock dependencies for Multiplatform Gradle Projects.
Why it matters now
EPSS 0.02212 82nd percentileScored 2026-11-07
Fix Fixed org.jetbrains.kotlin:kotlin-stdlib (Maven): 1.6.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | org.jetbrains.kotlin:kotlin-stdlib (Maven) | before 1.6.0 | 1.6.0 | Patch available | GHSA-2qp4-g3q3-f92w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- org.jetbrains.kotlin:kotlin-stdlib (Maven) Vendor— Affected before 1.6.0 Fixed in 1.6.0 Patch available GHSA-2qp4-g3q3-f92w
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jetbrains:kotlin:*:*:*:*:*:*:*:* | before 1.6.0 | Vulnerable | JetBrains |
| cpe:2.3:a:oracle:communications_cloud_native_core_binding_support_function:22.1.3:*:*:*:*:*:*:* | 22.1.3 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:communications_pricing_design_center:12.0.0.4:*:*:*:*:*:*:* | 12.0.0.4 | Vulnerable | Oracle |
| cpe:2.3:a:oracle:communications_pricing_design_center:12.0.0.5:*:*:*:*:*:*:* | 12.0.0.5 | Vulnerable | Oracle |
- cpe:2.3:a:jetbrains:kotlin:*:*:*:*:*:*:*:* Versions before 1.6.0 Vulnerable ·JetBrains
- cpe:2.3:a:oracle:communications_cloud_native_core_binding_support_function:22.1.3:*:*:*:*:*:*:* Versions 22.1.3 Vulnerable ·Oracle
- cpe:2.3:a:oracle:communications_pricing_design_center:12.0.0.4:*:*:*:*:*:*:* Versions 12.0.0.4 Vulnerable ·Oracle
- cpe:2.3:a:oracle:communications_pricing_design_center:12.0.0.5:*:*:*:*:*:*:* Versions 12.0.0.5 Vulnerable ·Oracle
Remediation
- Fix · GHSA-2qp4-g3q3-f92w org.jetbrains.kotlin:kotlin-stdlib (Maven) Fixed in 1.6.0 Advisory →
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
Not affected: 16 products
- A-MQ Clients 2
- Red Hat AMQ Broker 7
- Red Hat Data Grid 8
- Red Hat Fuse 7
- Red Hat Integration Camel K 1
- Red Hat Integration Camel Quarkus 1
- Red Hat Integration Data Virtualisation Operator
- Red Hat Integration Service Registry
- Red Hat JBoss Data Grid 7
- Red Hat JBoss Enterprise Application Platform 7
- Red Hat JBoss Enterprise Application Platform Expansion Pack
- Red Hat OpenShift Application Runtimes
- Red Hat build of Apicurio Registry 2
- Red Hat build of Debezium 1
- Red Hat build of Quarkus
- streams for Apache Kafka
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24329
- 2026-10-03 Alias added: GHSA-2qp4-g3q3-f92w
References
Patch 2
Advisory 2
Sources
- CVE-2022-24329 · CVE Program
- CVE-2022-24329 · NVD
- FIRST EPSS
- GHSA-2qp4-g3q3-f92w · GitHub Advisory Database · CC BY 4.0
- CVE-2022-24329 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences