Read the docs
TI-2022-08312 Aliases CVE-2022-24440GHSA-7627-mp87-jf6q

Command injection in cocoapods-downloader

Priority MEDIUM 47CWE-88Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-88.

Summary

The package cocoapods-downloader before 1.6.0, from 1.6.2 and before 1.6.3 are vulnerable to Command Injection via git argument injection. When calling the Pod::Downloader.preprocess_options function and using git, both the git and branch parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.

Why it matters now

EPSS 0.0262 85th percentileScored 2026-11-07
Fix Fixed cocoapods-downloader: 1.6.0, 1.6.3cocoapods-downloader (RubyGems): 1.6.0, 1.6.3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—cocoapods-downloaderbefore 1.6.0; 1.6.2 and later; before 1.6.31.6.0, 1.6.3Patch availableCNA
—cocoapods-downloader (RubyGems)before 1.6.01.6.0Patch availableGHSA-7627-mp87-jf6q
—cocoapods-downloader (RubyGems)1.6.2 to before 1.6.31.6.3Patch availableGHSA-7627-mp87-jf6q
  • cocoapods-downloader Vendor— Affected before 1.6.0; 1.6.2 and later; before 1.6.3 Fixed in 1.6.0, 1.6.3 Patch available CNA
  • cocoapods-downloader (RubyGems) Vendor— Affected before 1.6.0 Fixed in 1.6.0 Patch available GHSA-7627-mp87-jf6q
  • cocoapods-downloader (RubyGems) Vendor— Affected 1.6.2 to before 1.6.3 Fixed in 1.6.3 Patch available GHSA-7627-mp87-jf6q

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:cocoapods:cocoapods-downloader:*:*:*:*:*:*:*:*before 1.6.0VulnerableCocoaPods
cpe:2.3:a:cocoapods:cocoapods-downloader:1.6.2:*:*:*:*:*:*:*1.6.2VulnerableCocoaPods
  • cpe:2.3:a:cocoapods:cocoapods-downloader:*:*:*:*:*:*:*:* Versions before 1.6.0 Vulnerable ·CocoaPods
  • cpe:2.3:a:cocoapods:cocoapods-downloader:1.6.2:*:*:*:*:*:*:* Versions 1.6.2 Vulnerable ·CocoaPods

Remediation

  • Fix · CNA cocoapods-downloader Fixed in 1.6.0, 1.6.3
  • Fix · GHSA-7627-mp87-jf6q cocoapods-downloader (RubyGems) Fixed in 1.6.0 Advisory →
  • Fix · GHSA-7627-mp87-jf6q cocoapods-downloader (RubyGems) Fixed in 1.6.3 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24440
  2. 2026-10-03 Alias added: GHSA-7627-mp87-jf6q

References

  • TI-2022-05616 Command injection in cocoapods-downloader CVSS 3.1CRITICAL 9.8

Sources