Code injection in snyk
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
The package snyk before 1.1064.0 are vulnerable to Code Injection when analyzing a project. An attacker who can convince a user to scan a malicious project can include commands in a build file such as build.gradle or gradle-wrapper.jar, which will be executed with the privileges of the application. This vulnerability may be triggered when running the the CLI tool directly, or when running a scan with one of the IDE plugins that invoke the Snyk CLI. Successful exploitation of this issue would likely require some level of social engineering - to coerce an untrusted project to be downloaded and analyzed via the Snyk CLI or opened in an IDE where a Snyk IDE plugin is installed and enabled. Additionally, if the IDE has a Trust feature then the target folder must be marked as ‘trusted’ in order to be vulnerable. **NOTE:** This issue is independent of the one reported in [CVE-2022-40764](https://security.snyk.io/vuln/SNYK-JS-SNYK-3037342), and upgrading to a fixed version for this addresses that issue as well. The affected IDE plugins and versions are: - VS Code - Affected: <=1.8.0, Fixed: 1.9.0 - IntelliJ - Affected: <=2.4.47, Fixed: 2.4.48 - Visual Studio - Affected: <=1.1.30, Fixed: 1.1.31 - Eclipse - Affected: <=v20221115.132308, Fixed: All subsequent versions - Language Server - Affected: <=v20221109.114426, Fixed: All subsequent versions
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | snyk | before 1.1064.0 | 1.1064.0 | Patch available | CNA |
| — | snyk (npm) | before 1.1064.0 | 1.1064.0 | Patch available | GHSA-4vrv-93c7-m92j |
- snyk Vendor— Affected before 1.1064.0 Fixed in 1.1064.0 Patch available CNA
- snyk (npm) Vendor— Affected before 1.1064.0 Fixed in 1.1064.0 Patch available GHSA-4vrv-93c7-m92j
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:snyk:snyk_cli:*:*:*:*:*:*:*:* | before 1.1064.0 | Vulnerable | Snyk |
| cpe:2.3:a:snyk:snyk_language_server:*:*:*:*:*:*:*:* | up to 20221109.114426 | Vulnerable | Snyk |
| cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:visual_studio:*:* | up to 1.1.30 | Vulnerable | Snyk |
| cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:visual_studio_code:*:* | up to 1.8.0 | Vulnerable | Snyk |
| cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:intellij:*:* | up to 2.4.47 | Vulnerable | Snyk |
| cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:eclipse:*:* | up to 20221115.132308 | Vulnerable | Snyk |
- cpe:2.3:a:snyk:snyk_cli:*:*:*:*:*:*:*:* Versions before 1.1064.0 Vulnerable ·Snyk
- cpe:2.3:a:snyk:snyk_language_server:*:*:*:*:*:*:*:* Versions up to 20221109.114426 Vulnerable ·Snyk
- cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:visual_studio:*:* Versions up to 1.1.30 Vulnerable ·Snyk
- cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:visual_studio_code:*:* Versions up to 1.8.0 Vulnerable ·Snyk
- cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:intellij:*:* Versions up to 2.4.47 Vulnerable ·Snyk
- cpe:2.3:a:snyk:snyk_security:*:*:*:*:*:eclipse:*:* Versions up to 20221115.132308 Vulnerable ·Snyk
Remediation
- Fix · CNA snyk Fixed in 1.1064.0
- Fix · GHSA-4vrv-93c7-m92j snyk (npm) Fixed in 1.1064.0 Advisory →
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
snyk 1.1064.0
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2022-07159 Command injection in snykPriority MEDIUM 61
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24441
- 2026-10-03 Alias added: GHSA-4vrv-93c7-m92j
References
Patch 5
- https://github.com/snyk/vscode-extension/commit/0db3b4240be0db6a0a5c6d02c0d4231a2c4ba708
- https://github.com/snyk/snyk-intellij-plugin/commit/56682f4ba6081ce1d95cb980cbfacd3809a826f4
- https://github.com/snyk/snyk-visual-studio-plugin/commit/0b53dbbd4a3153c3ef9aaf797af3b5caad0f731a
- https://github.com/snyk/snyk-eclipse-plugin/commit/b5a8bce25a359ced75f83a729fc6b2393fc9a495
- https://github.com/snyk/snyk-ls/commit/b3229f0142f782871aa72d1a7dcf417546d568ed
More Snyk Cli vulnerabilities
- TI-2022-07159 Command injection in snyk CVSS 3.1MEDIUM 6.3
- TI-2024-32649 OS command injection in Snyk Cli CVSS 4.0HIGH 7.5
- TI-2024-32648 OS command injection in Snyk Cli CVSS 4.0HIGH 7.5
- TI-2025-06016 Sensitive information in log files in snyk CVSS 4.0LOW 2.4
Sources
- CVE-2022-24441 · CVE Program
- CVE-2022-24441 · NVD
- FIRST EPSS
- GHSA-4vrv-93c7-m92j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences