HashiCorp Nomad and Nomad Enterprise 1.0.17, 1.1.11, and 1.2.5 allow invalid HCL for the…
Priority LOW 36CWE-770Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-770.
Summary
HashiCorp Nomad and Nomad Enterprise 1.0.17, 1.1.11, and 1.2.5 allow invalid HCL for the jobs parse endpoint, which may cause excessive CPU usage. Fixed in 1.0.18, 1.1.12, and 1.2.6.
Why it matters now
EPSS 0.01548 75th percentileScored 2026-11-07
Fix Fixed github.com/hashicorp/nomad (Go): 1.0.17, 1.1.12, 1.2.6
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | github.com/hashicorp/nomad (Go) | 1.0.0 to before 1.0.17 | 1.0.17 | Patch available | GHSA-3382-r9q8-4hfg |
| — | github.com/hashicorp/nomad (Go) | 1.1.0 to before 1.1.12 | 1.1.12 | Patch available | GHSA-3382-r9q8-4hfg |
| — | github.com/hashicorp/nomad (Go) | 1.2.0 to before 1.2.6 | 1.2.6 | Patch available | GHSA-3382-r9q8-4hfg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- github.com/hashicorp/nomad (Go) Vendor— Affected 1.0.0 to before 1.0.17 Fixed in 1.0.17 Patch available GHSA-3382-r9q8-4hfg
- github.com/hashicorp/nomad (Go) Vendor— Affected 1.1.0 to before 1.1.12 Fixed in 1.1.12 Patch available GHSA-3382-r9q8-4hfg
- github.com/hashicorp/nomad (Go) Vendor— Affected 1.2.0 to before 1.2.6 Fixed in 1.2.6 Patch available GHSA-3382-r9q8-4hfg
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* | 1.0.0 – 1.0.17 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | 1.0.0 – 1.0.17 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* | 1.1.0 to before 1.1.12 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | 1.1.0 to before 1.1.12 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* | 1.2.0 to before 1.2.6 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* | 1.2.0 to before 1.2.6 | Vulnerable | HashiCorp |
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* Versions 1.0.0 – 1.0.17 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions 1.0.0 – 1.0.17 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* Versions 1.1.0 to before 1.1.12 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions 1.1.0 to before 1.1.12 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:-:*:*:* Versions 1.2.0 to before 1.2.6 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:nomad:*:*:*:*:enterprise:*:*:* Versions 1.2.0 to before 1.2.6 Vulnerable ·HashiCorp
Remediation
- Fix · GHSA-3382-r9q8-4hfg github.com/hashicorp/nomad (Go) Fixed in 1.0.17 Advisory →
- Fix · GHSA-3382-r9q8-4hfg github.com/hashicorp/nomad (Go) Fixed in 1.1.12 Advisory →
- Fix · GHSA-3382-r9q8-4hfg github.com/hashicorp/nomad (Go) Fixed in 1.2.6 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24685
- 2026-10-03 Alias added: GHSA-3382-r9q8-4hfg
References
Advisory 4
More HashiCorp Nomad vulnerabilities
- TI-2019-09419 HashiCorp Nomad 0.9.0 through 0.9.1 has Incorrect Access Control via the exec driver. CVSS 3.0CRITICAL 9.8
- TI-2022-12559 HashiCorp Nomad and Nomad Enterprise version 0.2.0 up to 1.3.0 were impacted by go-getter… CVSS 3.1CRITICAL 9.8
- TI-2023-01674 Nomad Unauthenticated Client Agent HTTP Request Privilege Escalation CVSS 3.1CRITICAL 10.0
- TI-2020-06436 HashiCorp Nomad and Nomad Enterprise up to 0.10.2 incorrectly validated role/region… CVSS 3.1CRITICAL 9.8
- TI-2020-16532 HashiCorp Nomad and Nomad Enterprise version 0.9.0 up to 0.12.5 client file sandbox… CVSS 3.1CRITICAL 9.1
- TI-2021-19357 HashiCorp Nomad and Nomad Enterprise up to 1.0.13, 1.1.7, and 1.2.0, with the QEMU task… CVSS 3.1HIGH 8.8
Sources
- CVE-2022-24685 · CVE Program
- CVE-2022-24685 · NVD
- FIRST EPSS
- GHSA-3382-r9q8-4hfg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences