OS command injection in Apache Kylin
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Kylin's cube designer function has a command injection vulnerability when overwriting system parameters in the configuration overwrites menu. RCE can be implemented by closing the single quotation marks around the parameter value of “-- conf=” to inject any operating system command into the command line parameters. This vulnerability affects Kylin 2 version 2.6.5 and earlier, Kylin 3 version 3.1.2 and earlier, and Kylin 4 version 4.0.1 and earlier.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kylin | Apache Kylin 2 to before 2.6.6; Apache Kylin 3 – 3.1.2; Apache Kylin 4 – 4.0.1 | 2.6.6 | Patch available | CNA |
| — | org.apache.kylin:kylin-core-common (Maven) | before 4.0.2 | 4.0.2 | Patch available | GHSA-ppxx-m926-g569 |
| — | org.apache.kylin:kylin-spark-project (Maven) | before 4.0.2 | 4.0.2 | Patch available | GHSA-ppxx-m926-g569 |
| — | org.apache.kylin:kylin-server-base (Maven) | before 4.0.2 | 4.0.2 | Patch available | GHSA-ppxx-m926-g569 |
- Apache Kylin VendorApache Affected Apache Kylin 2 to before 2.6.6; Apache Kylin 3 – 3.1.2; Apache Kylin 4 – 4.0.1 Fixed in 2.6.6 Patch available CNA
- org.apache.kylin:kylin-core-common (Maven) Vendor— Affected before 4.0.2 Fixed in 4.0.2 Patch available GHSA-ppxx-m926-g569
- org.apache.kylin:kylin-spark-project (Maven) Vendor— Affected before 4.0.2 Fixed in 4.0.2 Patch available GHSA-ppxx-m926-g569
- org.apache.kylin:kylin-server-base (Maven) Vendor— Affected before 4.0.2 Fixed in 4.0.2 Patch available GHSA-ppxx-m926-g569
Remediation
- Fix · CNA Apache Kylin (Apache Software Foundation) Fixed in 2.6.6
- Fix · GHSA-ppxx-m926-g569 org.apache.kylin:kylin-core-common (Maven) Fixed in 4.0.2 Advisory →
- Fix · GHSA-ppxx-m926-g569 org.apache.kylin:kylin-spark-project (Maven) Fixed in 4.0.2 Advisory →
- Fix · GHSA-ppxx-m926-g569 org.apache.kylin:kylin-server-base (Maven) Fixed in 4.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24697
- 2026-10-03 Alias added: GHSA-ppxx-m926-g569
References
Patch 2
More Apache Kylin vulnerabilities
- TI-2020-01880 OS command injection in Apache Kylin KEVCVSS 3.1HIGH 8.8
- TI-2021-20543 Command injection in Apache Kylin CVSS 3.1CRITICAL 9.8
- TI-2022-21192 Apache Kylin: Command injection by Useless configuration CVSS 3.1HIGH 8.8
- TI-2020-10914 Insecure storage of sensitive information in Apache Kylin CVSS 3.1MEDIUM 5.3
- TI-2020-10903 OS command injection in Apache Kylin CVSS 3.1CRITICAL 9.8
- TI-2025-38136 Apache Kylin: improper restriction of file read CVSS 3.1HIGH 7.5
Sources
- CVE-2022-24697 · CVE Program
- CVE-2022-24697 · NVD
- FIRST EPSS
- GHSA-ppxx-m926-g569 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences