Unauthorized forwarding of confidential headers in fluture-node
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure, Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-359 and CWE-601.
Summary
Fluture-Node is a FP-style HTTP and streaming utils for Node based on Fluture. Using `followRedirects` or `followRedirectsWith` with any of the redirection strategies built into fluture-node 4.0.0 or 4.0.1, paired with a request that includes confidential headers such as Authorization or Cookie, exposes you to a vulnerability where, if the destination server were to redirect the request to a server on a third-party domain, or the same domain over unencrypted HTTP, the headers would be included in the follow-up request and be exposed to the third party, or potential http traffic sniffing. The redirection strategies made available in version 4.0.2 automatically redact confidential headers when a redirect is followed across to another origin. A workaround has been identified by using a custom redirection strategy via the `followRedirectsWith` function. The custom strategy can be based on the new strategies available in [email protected].
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| fluture-js | fluture-node | 4.0.0 to before 4.0.2 | 4.0.2 | Patch available | CNA |
| — | fluture-node (npm) | 4.0.0 to before 4.0.2 | 4.0.2 | Patch available | GHSA-32x6-qvw6-mxj4 |
- fluture-node Vendorfluture-js Affected 4.0.0 to before 4.0.2 Fixed in 4.0.2 Patch available CNA
- fluture-node (npm) Vendor— Affected 4.0.0 to before 4.0.2 Fixed in 4.0.2 Patch available GHSA-32x6-qvw6-mxj4
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fluture-node_project:fluture-node:4.0.0:*:*:*:*:node.js:*:* | 4.0.0 | Vulnerable | Fluture-node Project |
| cpe:2.3:a:fluture-node_project:fluture-node:4.0.1:*:*:*:*:node.js:*:* | 4.0.1 | Vulnerable | Fluture-node Project |
- cpe:2.3:a:fluture-node_project:fluture-node:4.0.0:*:*:*:*:node.js:*:* Versions 4.0.0 Vulnerable ·Fluture-node Project
- cpe:2.3:a:fluture-node_project:fluture-node:4.0.1:*:*:*:*:node.js:*:* Versions 4.0.1 Vulnerable ·Fluture-node Project
Remediation
- Fix · CNA fluture-node (fluture-js) Fixed in 4.0.2
- Fix · GHSA-32x6-qvw6-mxj4 fluture-node (npm) Fixed in 4.0.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24719
- 2026-10-03 Alias added: GHSA-32x6-qvw6-mxj4
References
Patch 4
- https://github.com/fluture-js/fluture-node/security/advisories/GHSA-32x6-qvw6-mxj4
- https://github.com/psf/requests/pull/4718
- https://github.com/fluture-js/fluture-node/commit/0c99bc511533d48be17dc6bfe641f7d0aeb34d77
- https://github.com/fluture-js/fluture-node/commit/125e4474f910c1507f8ec3232848626fbc0f55c4
Sources
- CVE-2022-24719 · CVE Program
- CVE-2022-24719 · NVD
- FIRST EPSS
- GHSA-32x6-qvw6-mxj4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences