Maddy Mail Server does not implement account expiry
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-613.
Summary
Maddy Mail Server is an open source SMTP compatible email server. Versions of maddy prior to 0.5.4 do not implement password expiry or account expiry checking when authenticating using PAM. Users are advised to upgrade. Users unable to upgrade should manually remove expired accounts via existing filtering mechanisms.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| foxcpp | maddy | before 0.5.4 | 0.5.4 | Patch available | CNA |
| — | github.com/foxcpp/maddy (Go) | before 0.5.4 | 0.5.4 | Patch available | GHSA-6cp7-g972-w9m9 |
- maddy Vendorfoxcpp Affected before 0.5.4 Fixed in 0.5.4 Patch available CNA
- github.com/foxcpp/maddy (Go) Vendor— Affected before 0.5.4 Fixed in 0.5.4 Patch available GHSA-6cp7-g972-w9m9
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:maddy_project:maddy:*:*:*:*:*:*:*:* | 0.5.0 to before 0.5.4 | Vulnerable | Maddy Project |
- cpe:2.3:a:maddy_project:maddy:*:*:*:*:*:*:*:* Versions 0.5.0 to before 0.5.4 Vulnerable ·Maddy Project
Remediation
- Fix · CNA maddy (foxcpp) Fixed in 0.5.4
- Fix · GHSA-6cp7-g972-w9m9 github.com/foxcpp/maddy (Go) Fixed in 0.5.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24732
- 2026-10-03 Alias added: GHSA-6cp7-g972-w9m9
References
Advisory 2
More foxcpp vulnerabilities
- TI-2026-29007 Maddy Mail Server: LDAP Filter Injection via Unsanitized Username CVSS 3.1HIGH 8.2
- TI-2023-12292 Full authentication bypass if SASL authorization username is specified CVSS 3.1CRITICAL 9.8
- TI-2021-18860 A Broken or Risky Cryptographic Algorithm exists in Max Mazurov Maddy before 0.5.2, which… CVSS 3.1HIGH 7.5
Sources
- CVE-2022-24732 · CVE Program
- CVE-2022-24732 · NVD
- FIRST EPSS
- GHSA-6cp7-g972-w9m9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences