Basic Cross-site Scripting and Unrestricted Upload of File with Dangerous Type in Sylius
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Code execution, Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-434 and CWE-80.
Summary
Sylius is an open source eCommerce platform. In versions prior to 1.9.10, 1.10.11, and 1.11.2, it is possible to upload an SVG file containing cross-site scripting (XSS) code in the admin panel. In order to perform a XSS attack, the file itself has to be open in a new card or loaded outside of the IMG tag. The problem applies both to the files opened on the admin panel and shop pages. The issue is fixed in versions 1.9.10, 1.10.11, and 1.11.2. As a workaround, require a library that adds on-upload file sanitization and overwrite the service before writing the file to the filesystem. The GitHub Security Advisory contains more specific information about the workaround.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sylius | Sylius | before 1.9.10; 1.10.0 to before 1.10.11; 1.11.0 to before 1.11.2 | 1.9.10, 1.10.11, 1.11.2 | Patch available | CNA |
| — | sylius/sylius (Packagist) | before 1.9.10 | 1.9.10 | Patch available | GHSA-4qrp-27r3-66fj |
| — | sylius/sylius (Packagist) | 1.10.0 to before 1.10.11 | 1.10.11 | Patch available | GHSA-4qrp-27r3-66fj |
| — | sylius/sylius (Packagist) | 1.11.0 to before 1.11.2 | 1.11.2 | Patch available | GHSA-4qrp-27r3-66fj |
- Sylius VendorSylius Affected before 1.9.10; 1.10.0 to before 1.10.11; 1.11.0 to before 1.11.2 Fixed in 1.9.10, 1.10.11, 1.11.2 Patch available CNA
- sylius/sylius (Packagist) Vendor— Affected before 1.9.10 Fixed in 1.9.10 Patch available GHSA-4qrp-27r3-66fj
- sylius/sylius (Packagist) Vendor— Affected 1.10.0 to before 1.10.11 Fixed in 1.10.11 Patch available GHSA-4qrp-27r3-66fj
- sylius/sylius (Packagist) Vendor— Affected 1.11.0 to before 1.11.2 Fixed in 1.11.2 Patch available GHSA-4qrp-27r3-66fj
Remediation
- Fix · CNA Sylius (Sylius) Fixed in 1.9.10, 1.10.11, 1.11.2
- Fix · GHSA-4qrp-27r3-66fj sylius/sylius (Packagist) Fixed in 1.9.10 Advisory →
- Fix · GHSA-4qrp-27r3-66fj sylius/sylius (Packagist) Fixed in 1.10.11 Advisory →
- Fix · GHSA-4qrp-27r3-66fj sylius/sylius (Packagist) Fixed in 1.11.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24749
- 2026-10-03 Alias added: GHSA-4qrp-27r3-66fj
References
Advisory 4
More Sylius vulnerabilities
- TI-2026-24374 Sylius is Missing Authorization in API v2 Add Item Endpoint CVSS 4.0MEDIUM 6.9
- TI-2022-08557 Insufficient Session Expiration in Sylius CVSS 3.1HIGH 8.2
- TI-2026-24378 Sylius has a DQL Injection via API Order Filters CVSS 3.1MEDIUM 5.3
- TI-2024-19437 Sylius 1.12.13 is vulnerable to Cross Site Scripting (XSS) via the "Province" field in Address Book. CVSS 3.1MEDIUM 6.4
- TI-2026-24377 Sylius has a Promotion Usage Limit Bypass via Race Condition CVSS 3.1HIGH 8.2
- TI-2024-37963 A rate limiting issue in Sylius v2.0.2 allows a remote attacker to perform unrestricted… CVSS 3.1HIGH 7.5
Sources
- CVE-2022-24749 · CVE Program
- CVE-2022-24749 · NVD
- FIRST EPSS
- GHSA-4qrp-27r3-66fj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences