SQL Injection through sorting parameters in SyliusGridBundle
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-89.
Summary
SyliusGridBundle is a package of generic data grids for Symfony applications. Prior to versions 1.10.1 and 1.11-rc2, values added at the end of query sorting were passed directly to the database. The maintainers do not know if this could lead to direct SQL injections but took steps to remediate the vulnerability. The issue is fixed in versions 1.10.1 and 1.11-rc2. As a workaround, overwrite the`Sylius\Component\Grid\Sorting\Sorter.php` class and register it in the container. More information about this workaround is available in the GitHub Security Advisory.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Sylius | SyliusGridBundle | before 1.10.1; 1.11-alpha, <= 1.11-rc | 1.10.1 | Patch available | CNA |
| — | sylius/grid-bundle (Packagist) | before 1.10.1 | 1.10.1 | Patch available | GHSA-2xmm-g482-4439 |
- SyliusGridBundle VendorSylius Affected before 1.10.1; 1.11-alpha, <= 1.11-rc Fixed in 1.10.1 Patch available CNA
- sylius/grid-bundle (Packagist) Vendor— Affected before 1.10.1 Fixed in 1.10.1 Patch available GHSA-2xmm-g482-4439
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sylius:syliusgridbundle:*:*:*:*:*:*:*:* | before 1.10.1 | Vulnerable | Sylius |
| cpe:2.3:a:sylius:syliusgridbundle:1.11.0:-:*:*:*:*:*:* | 1.11.0 | Vulnerable | Sylius |
| cpe:2.3:a:sylius:syliusgridbundle:1.11.0:alpha1:*:*:*:*:*:* | 1.11.0 alpha1 | Vulnerable | Sylius |
| cpe:2.3:a:sylius:syliusgridbundle:1.11.0:beta1:*:*:*:*:*:* | 1.11.0 beta1 | Vulnerable | Sylius |
| cpe:2.3:a:sylius:syliusgridbundle:1.11.0:rc1:*:*:*:*:*:* | 1.11.0 rc1 | Vulnerable | Sylius |
- cpe:2.3:a:sylius:syliusgridbundle:*:*:*:*:*:*:*:* Versions before 1.10.1 Vulnerable ·Sylius
- cpe:2.3:a:sylius:syliusgridbundle:1.11.0:-:*:*:*:*:*:* Versions 1.11.0 Vulnerable ·Sylius
- cpe:2.3:a:sylius:syliusgridbundle:1.11.0:alpha1:*:*:*:*:*:* Versions 1.11.0 alpha1 Vulnerable ·Sylius
- cpe:2.3:a:sylius:syliusgridbundle:1.11.0:beta1:*:*:*:*:*:* Versions 1.11.0 beta1 Vulnerable ·Sylius
- cpe:2.3:a:sylius:syliusgridbundle:1.11.0:rc1:*:*:*:*:*:* Versions 1.11.0 rc1 Vulnerable ·Sylius
Remediation
- Fix · CNA SyliusGridBundle (Sylius) Fixed in 1.10.1
- Fix · GHSA-2xmm-g482-4439 sylius/grid-bundle (Packagist) Fixed in 1.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24752
- 2026-10-03 Alias added: GHSA-2xmm-g482-4439
References
Patch 2
Advisory 4
Sources
- CVE-2022-24752 · CVE Program
- CVE-2022-24752 · NVD
- FIRST EPSS
- GHSA-2xmm-g482-4439 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences