Code injection in Stripe CLI on windows
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Stripe CLI is a command-line tool for the Stripe eCommerce platform. A vulnerability in Stripe CLI exists on Windows when certain commands are run in a directory where an attacker has planted files. The commands are `stripe login`, `stripe config -e`, `stripe community`, and `stripe open`. MacOS and Linux are unaffected. An attacker who successfully exploits the vulnerability can run arbitrary code in the context of the current user. The update addresses the vulnerability by throwing an error in these situations before the code can run.Users are advised to upgrade to version 1.7.13. There are no known workarounds for this issue.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| stripe | stripe-cli | before 1.7.13 | 1.7.13 | Patch available | CNA |
| — | github.com/stripe/stripe-cli (Go) | before 1.7.13 | 1.7.13 | Patch available | GHSA-4cx6-fj7j-pjx9 |
- stripe-cli Vendorstripe Affected before 1.7.13 Fixed in 1.7.13 Patch available CNA
- github.com/stripe/stripe-cli (Go) Vendor— Affected before 1.7.13 Fixed in 1.7.13 Patch available GHSA-4cx6-fj7j-pjx9
Remediation
- Fix · CNA stripe-cli (stripe) Fixed in 1.7.13
- Fix · GHSA-4cx6-fj7j-pjx9 github.com/stripe/stripe-cli (Go) Fixed in 1.7.13 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24753
- 2026-10-03 Alias added: GHSA-4cx6-fj7j-pjx9
References
More Stripe Cli vulnerabilities
- TI-2024-30450 stripe-cli Path Traversal vulnerability CVSS 3.1HIGH 7.6
Sources
- CVE-2022-24753 · CVE Program
- CVE-2022-24753 · NVD
- FIRST EPSS
- GHSA-4cx6-fj7j-pjx9 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences