Command Injection in Parse server
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.
Summary
Parse Server is an open source http web server backend. In versions prior to 4.10.7 there is a Remote Code Execution (RCE) vulnerability in Parse Server. This vulnerability affects Parse Server in the default configuration with MongoDB. The main weakness that leads to RCE is the Prototype Pollution vulnerable code in the file `DatabaseController.js`, so it is likely to affect Postgres and any other database backend as well. This vulnerability has been confirmed on Linux (Ubuntu) and Windows. Users are advised to upgrade as soon as possible. The only known workaround is to manually patch your installation with code referenced at the source GHSA-p6h4-93qp-jhcm.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| parse-community | parse-server | before 4.10.7 | 4.10.7 | Patch available | CNA |
| — | parse-server (npm) | before 4.10.7 | 4.10.7 | Patch available | GHSA-p6h4-93qp-jhcm |
- parse-server Vendorparse-community Affected before 4.10.7 Fixed in 4.10.7 Patch available CNA
- parse-server (npm) Vendor— Affected before 4.10.7 Fixed in 4.10.7 Patch available GHSA-p6h4-93qp-jhcm
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* | before 4.10.7 | Vulnerable | parse-community |
| cpe:2.3:o:canonical:ubuntu_linux:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Canonical |
| cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Microsoft |
- cpe:2.3:a:parseplatform:parse-server:*:*:*:*:*:node.js:*:* Versions before 4.10.7 Vulnerable ·parse-community
- cpe:2.3:o:canonical:ubuntu_linux:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Canonical
- cpe:2.3:o:microsoft:windows:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Microsoft
Remediation
- Fix · CNA parse-server (parse-community) Fixed in 4.10.7
- Fix · GHSA-p6h4-93qp-jhcm parse-server (npm) Fixed in 4.10.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24760
- 2026-10-03 Alias added: GHSA-p6h4-93qp-jhcm
References
Exploit 2
Patch 1
More parse-community Parse-server vulnerabilities
- TI-2024-18136 Parse Server literalizeRegexPart SQL Injection CVSS 3.1CRITICAL 10.0
- TI-2022-18768 Parse Server vulnerable to Remote Code Execution via prototype pollution in MongoDB BSON parser CVSS 3.1CRITICAL 9.8
- TI-2024-31550 Parse Server's custom object ID allows to acquire role privileges CVSS 3.1HIGH 8.1
- TI-2023-18316 Parse Server vulnerable to remote code execution via MongoDB BSON parser through prototype pollution CVSS 3.1CRITICAL 9.8
- TI-2026-23790 Parse Server session token exfiltration via `redirectClassNameForKey` query parameter CVSS 4.0CRITICAL 9.9
- TI-2026-24777 Parse Server: Account takeover via operator injection in authentication data identifier CVSS 4.0CRITICAL 9.3
Sources
- CVE-2022-24760 · CVE Program
- CVE-2022-24760 · NVD
- FIRST EPSS
- GHSA-p6h4-93qp-jhcm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences