Read the docs
TI-2022-08589 Aliases CVE-2022-24775GHSA-q7rv-6hp3-vh96

Improper Input Validation in guzzlehttp/psr7

Priority MEDIUM 44CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

guzzlehttp/psr7 is a PSR-7 HTTP message library. Versions prior to 1.8.4 and 2.1.1 are vulnerable to improper header parsing. An attacker could sneak in a new line character and pass untrusted values. The issue is patched in 1.8.4 and 2.1.1. There are currently no known workarounds.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.0248 84th percentileScored 2026-11-07
Fix Fixed psr7 (guzzle): 1.8.4, 2.1.1guzzlehttp/psr7 (Packagist): 1.8.4, 2.1.1

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
guzzlepsr7before 1.8.4; 2.0.0 to before 2.1.11.8.4, 2.1.1Patch availableCNA
—guzzlehttp/psr7 (Packagist)before 1.8.41.8.4Patch availableGHSA-q7rv-6hp3-vh96
—guzzlehttp/psr7 (Packagist)2.0.0 to before 2.1.12.1.1Patch availableGHSA-q7rv-6hp3-vh96
  • psr7 Vendorguzzle Affected before 1.8.4; 2.0.0 to before 2.1.1 Fixed in 1.8.4, 2.1.1 Patch available CNA
  • guzzlehttp/psr7 (Packagist) Vendor— Affected before 1.8.4 Fixed in 1.8.4 Patch available GHSA-q7rv-6hp3-vh96
  • guzzlehttp/psr7 (Packagist) Vendor— Affected 2.0.0 to before 2.1.1 Fixed in 2.1.1 Patch available GHSA-q7rv-6hp3-vh96

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:*8.0.0 to before 9.2.16; 9.3.0 to before 9.3.9VulnerableDrupal
cpe:2.3:a:guzzlephp:psr-7:*:*:*:*:*:*:*:*before 1.8.4; 2.0.0 to before 2.1.1Vulnerableguzzle
  • cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 8.0.0 to before 9.2.16; 9.3.0 to before 9.3.9 Vulnerable ·Drupal
  • cpe:2.3:a:guzzlephp:psr-7:*:*:*:*:*:*:*:* Versions before 1.8.4; 2.0.0 to before 2.1.1 Vulnerable ·guzzle

Remediation

  • Fix · CNA psr7 (guzzle) Fixed in 1.8.4, 2.1.1
  • Fix · GHSA-q7rv-6hp3-vh96 guzzlehttp/psr7 (Packagist) Fixed in 1.8.4 Advisory →
  • Fix · GHSA-q7rv-6hp3-vh96 guzzlehttp/psr7 (Packagist) Fixed in 2.1.1 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24775
  2. 2026-10-03 Alias added: GHSA-q7rv-6hp3-vh96

References

  • TI-2023-13898 Laminas Diactoros vulnerable to HTTP Multiline Header Termination CVSS 3.1HIGH 7.5
  • TI-2023-13625 Improper header name validation in guzzlehttp/psr7 CVSS 3.1HIGH 7.5
  • TI-2026-42696 guzzlehttp/psr7: Host Confusion via Weak URI Host Validation CVSS 3.1MEDIUM 6.5
  • TI-2026-36415 guzzlehttp/psr7 has CRLF Injection via URI Host Component CVSS 3.1MEDIUM 5.3
  • TI-2026-36252 guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation CVSS 3.1MEDIUM 5.3
  • TI-2026-40255 guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization CVSS 3.1MEDIUM 4.8

Sources