Command Injection vulnerability in asciidoctor-include-ext
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
Asciidoctor-include-ext is Asciidoctor’s standard include processor reimplemented as an extension. Versions prior to 0.4.0, when used to render user-supplied input in AsciiDoc markup, may allow an attacker to execute arbitrary system commands on the host operating system. This attack is possible even when `allow-uri-read` is disabled! The problem has been patched in the referenced commits.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| jirutka | asciidoctor-include-ext | before 0.4.0 | 0.4.0 | Patch available | CNA |
| — | asciidoctor-include-ext (RubyGems) | before 0.4.0 | 0.4.0 | Patch available | GHSA-v222-6mr4-qj29 |
- asciidoctor-include-ext Vendorjirutka Affected before 0.4.0 Fixed in 0.4.0 Patch available CNA
- asciidoctor-include-ext (RubyGems) Vendor— Affected before 0.4.0 Fixed in 0.4.0 Patch available GHSA-v222-6mr4-qj29
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:asciidoctor-include-ext_project:asciidoctor-include-ext:*:*:*:*:*:*:*:* | before 0.4.0 | Vulnerable | Asciidoctor-include-ext Project |
- cpe:2.3:a:asciidoctor-include-ext_project:asciidoctor-include-ext:*:*:*:*:*:*:*:* Versions before 0.4.0 Vulnerable ·Asciidoctor-include-ext Project
Remediation
- Fix · CNA asciidoctor-include-ext (jirutka) Fixed in 0.4.0
- Fix · GHSA-v222-6mr4-qj29 asciidoctor-include-ext (RubyGems) Fixed in 0.4.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24803
- 2026-10-03 Alias added: GHSA-v222-6mr4-qj29
References
Exploit 1
Patch 1
Advisory 2
Sources
- CVE-2022-24803 · CVE Program
- CVE-2022-24803 · NVD
- FIRST EPSS
- GHSA-v222-6mr4-qj29 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences