Heap overflow issue with the Lua cjson library used by Redis
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 2 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-122 and the CVSS impact.
Summary
Redis is an in-memory database that persists on disk. A specially crafted Lua script executing in Redis can trigger a heap overflow in the cjson library, and result with heap corruption and potentially remote code execution. The problem exists in all versions of Redis with Lua scripting support, starting from 2.6, and affects only authenticated and authorized users. The problem is fixed in versions 7.0.12, 6.2.13, and 6.0.20.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Redis | redis | 7.0.0 to before 7.0.12; 6.2.0 to before 6.2.13; 6.0.0 to before 6.0.20 | 7.0.12, 6.2.13, 6.0.20 | Patch available | CNA |
- redis VendorRedis Affected 7.0.0 to before 7.0.12; 6.2.0 to before 6.2.13; 6.0.0 to before 6.0.20 Fixed in 7.0.12, 6.2.13, 6.0.20 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:* | 2.6.0 to before 6.0.20; 6.2.0 to before 6.2.13; 7.0.0 to before 7.0.12 | Vulnerable | Redis |
| cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* | 37 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* | 38 | Vulnerable | Fedoraproject |
- cpe:2.3:a:redis:redis:*:*:*:*:*:*:*:* Versions 2.6.0 to before 6.0.20; 6.2.0 to before 6.2.13; 7.0.0 to before 7.0.12 Vulnerable ·Redis
- cpe:2.3:o:fedoraproject:fedora:37:*:*:*:*:*:*:* Versions 37 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:38:*:*:*:*:*:*:* Versions 38 Vulnerable ·Fedoraproject
Remediation
- Fix · CNA redis (redis) Fixed in 7.0.12, 6.2.13, 6.0.20
Red Hat 2 advisories
- RHSA-2025:0693 Released 2025-01-27 · Red Hat rating Importantredis security update
- Red Hat Enterprise Linux AppStream (v. 9) redis-6.2.17-1.el9_5, redis-devel-6.2.17-1.el9_5, redis-doc-6.2.17-1.el9_5
- RHSA-2025:0595 Released 2025-01-22 · Red Hat rating Importantredis:6 security update
- Red Hat Enterprise Linux AppStream (v. 8) redis-6.2.17-1.module+el8.10.0+22680+748527fd.aarch64::redis:6, redis-6.2.17-1.module+el8.10.0+22680+748527fd.ppc64le::redis:6, redis-6.2.17-1.module+el8.10.0+22680+748527fd.s390x::redis:6 +7
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat 3scale API Management Platform 2 | Affected | No fix yet |
| Red Hat Software Collections | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2025:0595 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2025:0693 |
Not affected: 10 products
- Red Hat Advanced Cluster Management for Kubernetes 2
- Red Hat Ansible Automation Platform 1.2
- Red Hat Enterprise Linux 9
- Red Hat Fuse 7
- Red Hat OpenStack Platform 16.1
- Red Hat OpenStack Platform 16.2
- Red Hat OpenStack Platform 17.0
- Red Hat OpenStack Platform 17.1
- Red Hat OpenStack Platform 18.0
- Red Hat Satellite 6
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24834
References
Advisory 3
More Redis vulnerabilities
- TI-2022-00463 Missing authorization in Debian redis KEVCVSS 3.1CRITICAL 10.0
- TI-2025-31759 Redis Lua Use-After-Free may lead to remote code execution CVSS 3.1CRITICAL 10.0
- TI-2023-18618 Heap overflow in COMMAND GETKEYS and ACL evaluation in Redis CVSS 3.1HIGH 8.8
- TI-2024-20813 Lua library commands may lead to stack overflow and RCE in Redis CVSS 3.1HIGH 8.8
- TI-2022-08549 Lua scripts can be manipulated to overcome ACL rules in Redis CVSS 3.1HIGH 7.8
- TI-2023-08708 Integer overflow in multiple Redis commands can lead to denial-of-service CVSS 3.1MEDIUM 5.5
Sources
- CVE-2022-24834 · CVE Program
- CVE-2022-24834 · NVD
- FIRST EPSS
- CVE-2022-24834 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences