Read the docs
TI-2022-08672 Aliases CVE-2022-24861

Remote Code Execution in Databasir

Priority HIGH 76CWE-20Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

Databasir is a team-oriented relational database model document management platform. Databasir 1.01 has remote code execution vulnerability. JDBC drivers are not validated prior to use and may be provided by users of the system. This can lead to code execution by any basic user who has access to the system. Users are advised to upgrade. There are no known workarounds to this issue.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.03049 87th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed databasir (vran-dev): 1.0.2

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Total

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
vran-devdatabasirbefore 1.0.21.0.2Patch availableCNA
  • databasir Vendorvran-dev Affected before 1.0.2 Fixed in 1.0.2 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:databasir:databasir:1.0.1:*:*:*:*:*:*:*1.0.1VulnerableDatabasir
  • cpe:2.3:a:databasir:databasir:1.0.1:*:*:*:*:*:*:* Versions 1.0.1 Vulnerable ·Databasir

Remediation

  • Fix · CNA databasir (vran-dev) Fixed in 1.0.2

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-24861

References

  • TI-2025-41090 SQL Injection vulnerability in vran-dev databaseir v.1.0.7 and before allows a remote… CVSS 3.1CRITICAL 9.8
  • TI-2023-12435 Databasir v1.0.7 was discovered to contain a remote code execution (RCE) vulnerability via the mockDataScript parameter. CVSS 3.1CRITICAL 9.8
  • TI-2022-13236 Server-Side Request Forgery (SSRF) vulnerability in Databasir CVSS 3.1HIGH 7.6

Sources

This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences