Espressif Bluetooth Mesh Stack Vulnerable to Out-of-bounds Write leading to memory buffer corruption
Key facts
- Attack vector
- Adjacent network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-787 and the CVSS impact.
Summary
ESP-IDF is the official development framework for Espressif SoCs. In Espressif’s Bluetooth Mesh SDK (`ESP-BLE-MESH`), a memory corruption vulnerability can be triggered during provisioning, because there is no check for the `SegN` field of the Transaction Start PDU. This can result in memory corruption related attacks and potentially attacker gaining control of the entire system. Patch commits are available on the 4.1, 4.2, 4.3 and 4.4 branches and users are recommended to upgrade. The upgrade is applicable for all applications and users of `ESP-BLE-MESH` component from `ESP-IDF`. As it is implemented in the Bluetooth Mesh stack, there is no workaround for the user to fix the application layer without upgrading the underlying firmware.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| espressif | esp-idf | before 4.1.4; > 4.2.0, < 4.2.4; > 4.3.2, < 4.3.3; > 4.4.1, < 4.4.2 | 4.1.4 | Patch available | CNA |
- esp-idf Vendorespressif Affected before 4.1.4; > 4.2.0, < 4.2.4; > 4.3.2, < 4.3.3; > 4.4.1, < 4.4.2 Fixed in 4.1.4 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:espressif:esp-idf:4.1.3:*:*:*:*:*:*:* | 4.1.3 | Vulnerable | espressif |
| cpe:2.3:a:espressif:esp-idf:4.2.3:*:*:*:*:*:*:* | 4.2.3 | Vulnerable | espressif |
| cpe:2.3:a:espressif:esp-idf:4.3.2:*:*:*:*:*:*:* | 4.3.2 | Vulnerable | espressif |
| cpe:2.3:a:espressif:esp-idf:4.4.1:*:*:*:*:*:*:* | 4.4.1 | Vulnerable | espressif |
- cpe:2.3:a:espressif:esp-idf:4.1.3:*:*:*:*:*:*:* Versions 4.1.3 Vulnerable ·espressif
- cpe:2.3:a:espressif:esp-idf:4.2.3:*:*:*:*:*:*:* Versions 4.2.3 Vulnerable ·espressif
- cpe:2.3:a:espressif:esp-idf:4.3.2:*:*:*:*:*:*:* Versions 4.3.2 Vulnerable ·espressif
- cpe:2.3:a:espressif:esp-idf:4.4.1:*:*:*:*:*:*:* Versions 4.4.1 Vulnerable ·espressif
Remediation
- Fix · CNA esp-idf (espressif) Fixed in 4.1.4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24893
More espressif Esp-idf vulnerabilities
- TI-2024-22076 Buffer Overflow vulnerability in esp-idf v.5.1 allows a remote attacker to execute… CVSS 3.1MEDIUM 6.5
- TI-2026-33125 ESF-IDF: Out-of-Bounds Write in ESP-TEE Secure Service Wrappers CVSS 3.1CRITICAL 9.3
- TI-2025-32598 ESP-NOW Integer Underflow Vulnerability Advisory CVSS 4.0HIGH 7.2
- TI-2021-09371 The Bluetooth Classic implementation in Espressif ESP-IDF 4.4 and earlier does not… CVSS 3.1HIGH 8.8
- TI-2026-33292 ESF-IDF: Remote Null Pointer Dereference in WebSocket Server CVSS 3.1HIGH 7.5
- TI-2024-35792 Espressif Esp idf v5.3.0 is vulnerable to Insecure Permissions resulting in… CVSS 3.1HIGH 8.8
Sources
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences