The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG…
Priority LOW 26CWE-88Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
The Crypt_GPG extension before 1.6.7 for PHP does not prevent additional options in GPG calls, which presents a risk for certain environments and GPG versions.
Why it matters now
EPSS 0.0085 58th percentileScored 2026-11-07
Fix Fixed pear/crypt_gpg (Packagist): 1.6.7
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | pear/crypt_gpg (Packagist) | before 1.6.7 | 1.6.7 | Patch available | GHSA-59x4-67mh-px54 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- pear/crypt_gpg (Packagist) Vendor— Affected before 1.6.7 Fixed in 1.6.7 Patch available GHSA-59x4-67mh-px54
Remediation
- Fix · GHSA-59x4-67mh-px54 pear/crypt_gpg (Packagist) Fixed in 1.6.7 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24953
- 2026-10-03 Alias added: GHSA-59x4-67mh-px54
References
Sources
- CVE-2022-24953 · CVE Program
- CVE-2022-24953 · NVD
- FIRST EPSS
- GHSA-59x4-67mh-px54 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-24953 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences