Command injection in p4
Priority HIGH 76CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
The package p4 before 0.0.7 are vulnerable to Command Injection via the run() function due to improper input sanitization
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.0247 84th percentileScored 2026-11-07
Fix Fixed p4: 0.0.7p4 (npm): 0.0.7
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | p4 | before 0.0.7 | 0.0.7 | Patch available | CNA |
| — | p4 (npm) | before 0.0.7 | 0.0.7 | Patch available | GHSA-jfm8-hwhg-r6gg |
- p4 Vendor— Affected before 0.0.7 Fixed in 0.0.7 Patch available CNA
- p4 (npm) Vendor— Affected before 0.0.7 Fixed in 0.0.7 Patch available GHSA-jfm8-hwhg-r6gg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:p4_project:p4:*:*:*:*:*:node.js:*:* | before 0.0.7 | Vulnerable | P4 Project |
- cpe:2.3:a:p4_project:p4:*:*:*:*:*:node.js:*:* Versions before 0.0.7 Vulnerable ·P4 Project
Remediation
- Fix · CNA p4 Fixed in 0.0.7
- Fix · GHSA-jfm8-hwhg-r6gg p4 (npm) Fixed in 0.0.7 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25171
- 2026-10-03 Alias added: GHSA-jfm8-hwhg-r6gg
References
Sources
- CVE-2022-25171 · CVE Program
- CVE-2022-25171 · NVD
- FIRST EPSS
- GHSA-jfm8-hwhg-r6gg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences