Cross-site scripting in Jenkins Generic Webhook Trigger Plugin
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins Generic Webhook Trigger Plugin 1.81 and earlier does not escape the build cause when using the webhook, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.00658 51st percentileScored 2026-11-07
Fix Fixed org.jenkins-ci.plugins:generic-webhook-trigger (Maven): 1.82
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Generic Webhook Trigger Plugin | up to 1.81 | — | No fix listed | CNA |
| — | org.jenkins-ci.plugins:generic-webhook-trigger (Maven) | before 1.82 | 1.82 | Patch available | GHSA-qqwx-hcp6-25vr |
- Jenkins Generic Webhook Trigger Plugin VendorJenkins Affected up to 1.81 Fixed in — No fix listed CNA
- org.jenkins-ci.plugins:generic-webhook-trigger (Maven) Vendor— Affected before 1.82 Fixed in 1.82 Patch available GHSA-qqwx-hcp6-25vr
Remediation
- Fix · GHSA-qqwx-hcp6-25vr org.jenkins-ci.plugins:generic-webhook-trigger (Maven) Fixed in 1.82 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25185
- 2026-10-03 Alias added: GHSA-qqwx-hcp6-25vr
- 2026-10-09 EPSS moved to the 50th–90th percentile
References
Advisory 2
More Jenkins Generic Webhook Trigger vulnerabilities
- TI-2021-04749 XML external entity injection in Jenkins Generic Webhook Trigger Plugin CVSS 3.1CRITICAL 9.8
- TI-2022-21207 Observable discrepancy in Jenkins Generic Webhook Trigger Plugin CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-25185 · CVE Program
- CVE-2022-25185 · NVD
- FIRST EPSS
- GHSA-qqwx-hcp6-25vr · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences