Missing authorization in Jenkins autonomiq Plugin
Priority LOW 21CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
A missing permission check in Jenkins autonomiq Plugin 1.15 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials.
Why it matters now
EPSS 0.0055 46th percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:autonomiq (Maven): 1.16
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins autonomiq Plugin | up to 1.15 | — | No fix listed | CNA |
| — | io.jenkins.plugins:autonomiq (Maven) | before 1.16 | 1.16 | Patch available | GHSA-6jv7-28mv-qp9c |
- Jenkins autonomiq Plugin VendorJenkins Affected up to 1.15 Fixed in — No fix listed CNA
- io.jenkins.plugins:autonomiq (Maven) Vendor— Affected before 1.16 Fixed in 1.16 Patch available GHSA-6jv7-28mv-qp9c
Remediation
- Fix · GHSA-6jv7-28mv-qp9c io.jenkins.plugins:autonomiq (Maven) Fixed in 1.16 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25195
- 2026-10-03 Alias added: GHSA-6jv7-28mv-qp9c
References
More Jenkins Autonomiq vulnerabilities
- TI-2022-08907 Cross-site request forgery in Jenkins autonomiq Plugin CVSS 3.1HIGH 8.8
Sources
- CVE-2022-25195 · CVE Program
- CVE-2022-25195 · NVD
- FIRST EPSS
- GHSA-6jv7-28mv-qp9c · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences