Silverstripe silverstripe/framework through 4.10.0 allows XSS, inside of script tags that…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Silverstripe silverstripe/framework through 4.10.0 allows XSS, inside of script tags that can can be added to website content via XHR by an authenticated CMS user if the cwp-core module is not installed on the sanitise_server_side contig is not set to true in project code.
Why it matters now
EPSS 0.00707 53rd percentileScored 2026-11-07
Fix Fixed silverstripe/framework (Packagist): 4.10.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/framework (Packagist) | 4.0.0 to before 4.10.9 | 4.10.9 | Patch available | GHSA-jx34-gqqq-r6gm |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/framework (Packagist) Vendor— Affected 4.0.0 to before 4.10.9 Fixed in 4.10.9 Patch available GHSA-jx34-gqqq-r6gm
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:framework:*:*:*:*:*:*:*:* | up to 4.10.0 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:framework:*:*:*:*:*:*:*:* Versions up to 4.10.0 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-jx34-gqqq-r6gm silverstripe/framework (Packagist) Fixed in 4.10.9 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25238
- 2026-10-03 Alias added: GHSA-jx34-gqqq-r6gm
References
Advisory 5
More silverstripe Framework vulnerabilities
- TI-2022-17852 Silverstripe silverstripe/framework through 4.11 allows SQL Injection. CVSS 3.1HIGH 8.8
- TI-2023-08903 Silverstripe Framework has open redirect vulnerability on CMSSecurity relogin screen CVSS 3.1MEDIUM 6.1
- TI-2022-18086 Silverstripe silverstripe/framework through 4.11 is vulnerable to XSS by carefully… CVSS 3.1MEDIUM 6.1
- TI-2022-18248 Silverstripe silverstripe/framework through 4.11.0, silverstripe/assets through 1.11.0… CVSS 3.1MEDIUM 5.4
- TI-2022-17851 Silverstripe silverstripe/framework through 4.11 allows XSS (issue 3 of 3). CVSS 3.1MEDIUM 5.4
- TI-2022-17850 Silverstripe silverstripe/framework through 4.11 allows XSS (issue 2 of 3). CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-25238 · CVE Program
- CVE-2022-25238 · NVD
- FIRST EPSS
- GHSA-jx34-gqqq-r6gm · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences