"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine…
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Will not fix Red Hat: no fix planned
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-295.
Summary
"Vault and Vault Enterprise 1.8.0 through 1.8.8, and 1.9.3 allowed the PKI secrets engine under certain configurations to issue wildcard certificates to authorized users for a specified domain, even if the PKI role policy attribute allow_subdomains is set to false. Fixed in Vault Enterprise 1.8.9 and 1.9.4.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* | 1.8.0 to before 1.8.9 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* | 1.8.0 to before 1.8.9 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* | 1.9.0 to before 1.9.4 | Vulnerable | HashiCorp |
| cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* | 1.9.0 to before 1.9.4 | Vulnerable | HashiCorp |
- cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* Versions 1.8.0 to before 1.8.9 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.8.0 to before 1.8.9 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:-:*:*:* Versions 1.9.0 to before 1.9.4 Vulnerable ·HashiCorp
- cpe:2.3:a:hashicorp:vault:*:*:*:*:enterprise:*:*:* Versions 1.9.0 to before 1.9.4 Vulnerable ·HashiCorp
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat OpenShift Container Platform 4 | Affected | No fix planned: Will not fix |
| Red Hat Openshift Container Storage 4 | Affected | No fix planned: Out of support scope |
| Red Hat Openshift Data Foundation 4 | Affected | No fix planned: Will not fix |
Not affected: 2 products
- Red Hat OpenShift Container Platform 4
- Red Hat Openshift Data Foundation 4
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25243
- 2026-10-03 Alias added: GHSA-p3j9-qwh2-784j
References
More HashiCorp Vault vulnerabilities
- TI-2024-01904 Vault Cert Auth Method Did Not Correctly Validate Non-CA Certificates CVSS 3.1CRITICAL 9.8
- TI-2022-19053 An issue was discovered in HashiCorp Vault and Vault Enterprise before 1.11.3. CVSS 3.1CRITICAL 9.1
- TI-2020-17874 The official vault docker images before 0.11.6 contain a blank password for a root user. CVSS 3.1CRITICAL 9.8
- TI-2020-10142 HashiCorp Vault and Vault Enterprise 1.4.0 and 1.4.1, when configured with the GCP… CVSS 3.1CRITICAL 9.8
- TI-2026-04407 Vault Vulnerable to Server-Side Request Forgery in ACME Challenge Validation via Attacker-Controlled DNS CVSS 3.1HIGH 8.6
- TI-2025-05421 Arbitrary Remote Code Execution via Plugin Catalog Abuse CVSS 3.1CRITICAL 9.1
Sources
- CVE-2022-25243 · CVE Program
- CVE-2022-25243 · NVD
- FIRST EPSS
- GHSA-p3j9-qwh2-784j · GitHub Advisory Database · CC BY 4.0
- CVE-2022-25243 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences