Command injection in git
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-88.
Summary
The package git before 1.11.0 are vulnerable to Command Injection via git argument injection. When calling the fetch(remote = 'origin', opts = {}) function, the remote parameter is passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | git | before 1.11.0 | 1.11.0 | Patch available | CNA |
| — | git (RubyGems) | before 1.11.0 | 1.11.0 | Patch available | GHSA-69p6-wvmq-27gg |
- git Vendor— Affected before 1.11.0 Fixed in 1.11.0 Patch available CNA
- git (RubyGems) Vendor— Affected before 1.11.0 Fixed in 1.11.0 Patch available GHSA-69p6-wvmq-27gg
CPE configurations NVD · 6
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:git:git:*:*:*:*:*:ruby:*:* | before 1.11.0 | Vulnerable | Git |
| cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:8.0:*:*:*:*:*:*:* | 8.0 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* | 34 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* | 35 | Vulnerable | Fedoraproject |
| cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* | 36 | Vulnerable | Fedoraproject |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:git:git:*:*:*:*:*:ruby:*:* Versions before 1.11.0 Vulnerable ·Git
- cpe:2.3:a:fedoraproject:extra_packages_for_enterprise_linux:8.0:*:*:*:*:*:*:* Versions 8.0 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:34:*:*:*:*:*:*:* Versions 34 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:35:*:*:*:*:*:*:* Versions 35 Vulnerable ·Fedoraproject
- cpe:2.3:o:fedoraproject:fedora:36:*:*:*:*:*:*:* Versions 36 Vulnerable ·Fedoraproject
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA git Fixed in 1.11.0
- Fix · GHSA-69p6-wvmq-27gg git (RubyGems) Fixed in 1.11.0 Advisory →
Red Hat 1 advisory
- RHSA-2022:8506 Released 2022-11-16 · Red Hat rating ImportantSatellite 6.12 Release
- Red Hat Satellite 6.12 for RHEL 8 candlepin-4.1.15-1.el8sat, candlepin-selinux-4.1.15-1.el8sat, foreman-3.3.0.17-1.el8sat +19
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Satellite 6.12 for RHEL 8 | Fixed | RHSA-2022:8506 |
Not affected: 1 product
- Red Hat Satellite 6.12 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25648
- 2026-10-03 Alias added: GHSA-69p6-wvmq-27gg
References
Advisory 5
Other 7
- https://github.com/ruby-git/ruby-git/releases/tag/v1.11.0
- https://github.com/ruby-git/ruby-git/commit/291ca0946bec7164b90ad5c572ac147f512c7159
- https://github.com/ruby-git/ruby-git
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/git/CVE-2022-25648.yml
- https://lists.fedoraproject.org/archives/list/[email protected]/message/PTJUF6SFPL4ZVSJQHGQ36KFPFO5DQVYZ
- https://lists.fedoraproject.org/archives/list/[email protected]/message/Q2V3HOFU4ZVTQZHAVAVL3EX2KU53SP7R
- https://lists.fedoraproject.org/archives/list/[email protected]/message/XWNJA7WPE67LJ3DJMWZ2TADHCZKWMY55
Sources
- CVE-2022-25648 · CVE Program
- CVE-2022-25648 · NVD
- FIRST EPSS
- GHSA-69p6-wvmq-27gg · GitHub Advisory Database · CC BY 4.0
- CVE-2022-25648 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences