Read the docs
TI-2022-09339 Aliases CVE-2022-25766GHSA-hf8c-xr89-vfm5

Remote code execution (RCE) in ungit

Priority MEDIUM 63CWE-88Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-88.

Summary

The package ungit before 1.5.20 are vulnerable to Remote Code Execution (RCE) via argument injection. The issue occurs when calling the /api/fetch endpoint. User controlled values (remote and ref) are passed to the git fetch command. By injecting some git options it was possible to get arbitrary command execution.

Why it matters now

EPSS 0.34543 98th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed ungit: 1.5.20ungit (npm): 1.5.20

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
—ungitbefore 1.5.201.5.20Patch availableCNA
—ungit (npm)before 1.5.201.5.20Patch availableGHSA-hf8c-xr89-vfm5
  • ungit Vendor— Affected before 1.5.20 Fixed in 1.5.20 Patch available CNA
  • ungit (npm) Vendor— Affected before 1.5.20 Fixed in 1.5.20 Patch available GHSA-hf8c-xr89-vfm5

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:ungit_project:ungit:*:*:*:*:*:node.js:*:*before 1.5.20VulnerableUngit Project
  • cpe:2.3:a:ungit_project:ungit:*:*:*:*:*:node.js:*:* Versions before 1.5.20 Vulnerable ·Ungit Project

Remediation

  • Fix · CNA ungit Fixed in 1.5.20
  • Fix · GHSA-hf8c-xr89-vfm5 ungit (npm) Fixed in 1.5.20 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-25766
  2. 2026-10-03 Alias added: GHSA-hf8c-xr89-vfm5

References

Sources