Denial of service (DoS) in pg-native
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Denial of service
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-704 and the CVSS impact.
Summary
All versions of package pg-native; all versions of package libpq are vulnerable to Denial of Service (DoS) when the addons attempt to cast the second argument to an array and fail. This happens for every non-array argument passed. **Note:** pg-native is a mere binding to npm's libpq library, which in turn has the addons and bindings to the actual C libpq library. This means that problems found in pg-native may transitively impact npm's libpq.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | pg-native | all versions | — | No fix listed | CNA |
| — | libpq | all versions | — | No fix listed | CNA |
| — | libpq (npm) | before 1.8.10 | 1.8.10 | Patch available | GHSA-j32j-2hxv-rqf7 |
| — | pg-native (npm) | before 3.0.1 | 3.0.1 | Patch available | GHSA-j32j-2hxv-rqf7 |
- pg-native Vendor— Affected all versions Fixed in — No fix listed CNA
- libpq Vendor— Affected all versions Fixed in — No fix listed CNA
- libpq (npm) Vendor— Affected before 1.8.10 Fixed in 1.8.10 Patch available GHSA-j32j-2hxv-rqf7
- pg-native (npm) Vendor— Affected before 3.0.1 Fixed in 3.0.1 Patch available GHSA-j32j-2hxv-rqf7
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libpq_project:libpq:*:*:*:*:*:node.js:*:* | all versions | Vulnerable | Libpq Project |
| cpe:2.3:a:pg-native_project:pg-native:*:*:*:*:*:node.js:*:* | all versions | Vulnerable | Pg-native Project |
- cpe:2.3:a:libpq_project:libpq:*:*:*:*:*:node.js:*:* Versions all versions Vulnerable ·Libpq Project
- cpe:2.3:a:pg-native_project:pg-native:*:*:*:*:*:node.js:*:* Versions all versions Vulnerable ·Pg-native Project
Remediation
- Fix · GHSA-j32j-2hxv-rqf7 libpq (npm) Fixed in 1.8.10 Advisory →
- Fix · GHSA-j32j-2hxv-rqf7 pg-native (npm) Fixed in 3.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25852
- 2026-10-03 Alias added: GHSA-j32j-2hxv-rqf7
References
Sources
- CVE-2022-25852 · CVE Program
- CVE-2022-25852 · NVD
- FIRST EPSS
- GHSA-j32j-2hxv-rqf7 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences