Command injection in workspace-tools
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
The package workspace-tools before 0.18.4 are vulnerable to Command Injection via git argument injection. When calling the fetchRemoteBranch(remote: string, remoteBranch: string, cwd: string) function, both the remote and remoteBranch parameters are passed to the git fetch subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | workspace-tools | before 0.18.4 | 0.18.4 | Patch available | CNA |
| — | workspace-tools (npm) | before 0.18.4 | 0.18.4 | Patch available | GHSA-5875-m6jq-vf78 |
- workspace-tools Vendor— Affected before 0.18.4 Fixed in 0.18.4 Patch available CNA
- workspace-tools (npm) Vendor— Affected before 0.18.4 Fixed in 0.18.4 Patch available GHSA-5875-m6jq-vf78
Remediation
- Fix · CNA workspace-tools Fixed in 0.18.4
- Fix · GHSA-5875-m6jq-vf78 workspace-tools (npm) Fixed in 0.18.4 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25865
- 2026-10-03 Alias added: GHSA-5875-m6jq-vf78
References
Sources
- CVE-2022-25865 · CVE Program
- CVE-2022-25865 · NVD
- FIRST EPSS
- GHSA-5875-m6jq-vf78 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences