Command injection in czproject/git-php
Priority MEDIUM 48CWE-88Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-88.
Summary
The package czproject/git-php before 4.0.3 are vulnerable to Command Injection via git argument injection. When calling the isRemoteUrlReadable($url, array $refs = NULL) function, both the url and refs parameters are passed to the git ls-remote subcommand in a way that additional flags can be set. The additional flags can be used to perform a command injection.
Why it matters now
EPSS 0.03649 89th percentileScored 2026-11-07
Fix Fixed czproject/git-php: 4.0.3czproject/git-php (Packagist): 4.0.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | czproject/git-php | before 4.0.3 | 4.0.3 | Patch available | CNA |
| — | czproject/git-php (Packagist) | before 4.0.3 | 4.0.3 | Patch available | GHSA-3xpw-vhmv-cw7h |
- czproject/git-php Vendor— Affected before 4.0.3 Fixed in 4.0.3 Patch available CNA
- czproject/git-php (Packagist) Vendor— Affected before 4.0.3 Fixed in 4.0.3 Patch available GHSA-3xpw-vhmv-cw7h
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:git-php_project:git-php:*:*:*:*:*:*:*:* | before 4.0.3 | Vulnerable | Git-php Project |
- cpe:2.3:a:git-php_project:git-php:*:*:*:*:*:*:*:* Versions before 4.0.3 Vulnerable ·Git-php Project
Remediation
- Fix · CNA czproject/git-php Fixed in 4.0.3
- Fix · GHSA-3xpw-vhmv-cw7h czproject/git-php (Packagist) Fixed in 4.0.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25866
- 2026-10-03 Alias added: GHSA-3xpw-vhmv-cw7h
References
Sources
- CVE-2022-25866 · CVE Program
- CVE-2022-25866 · NVD
- FIRST EPSS
- GHSA-3xpw-vhmv-cw7h · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences