Improper verification of cryptographic signature in jsrsasign
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-347.
Summary
The package jsrsasign before 10.5.25 are vulnerable to Improper Verification of Cryptographic Signature when JWS or JWT signature with non Base64URL encoding special characters or number escaped characters may be validated as valid by mistake. Workaround: Validate JWS or JWT signature if it has Base64URL and dot safe string before executing JWS.verify() or JWS.verifyJWT() method.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | jsrsasign | before 10.5.25 | 10.5.25 | Patch available | CNA |
| — | jsrsasign (npm) | 4.8.0 to before 10.5.25 | 10.5.25 | Patch available | GHSA-3fvg-4v2m-98jf |
- jsrsasign Vendor— Affected before 10.5.25 Fixed in 10.5.25 Patch available CNA
- jsrsasign (npm) Vendor— Affected 4.8.0 to before 10.5.25 Fixed in 10.5.25 Patch available GHSA-3fvg-4v2m-98jf
Remediation
- Fix · CNA jsrsasign Fixed in 10.5.25
- Fix · GHSA-3fvg-4v2m-98jf jsrsasign (npm) Fixed in 10.5.25 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-25898
- 2026-10-03 Alias added: GHSA-3fvg-4v2m-98jf
References
Advisory 2
More Kjur Jsrsasign vulnerabilities
- TI-2026-04006 Incorrect numeric conversion in jsrsasign CVSS 4.0HIGH 8.7
- TI-2026-04002 Infinite loop in jsrsasign CVSS 4.0HIGH 8.7
- TI-2026-04004 Improper signature verification in jsrsasign CVSS 4.0CRITICAL 9.1
- TI-2026-04003 Versions of the package jsrsasign from 7.0.0 and before 11.1.1 are vulnerable to… CVSS 4.0CRITICAL 9.3
- TI-2020-11771 An issue was discovered in the jsrsasign package before 8.0.17 for Node.js. CVSS 3.1CRITICAL 9.8
- TI-2020-11770 An issue was discovered in the jsrsasign package before 8.0.18 for Node.js. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-25898 · CVE Program
- CVE-2022-25898 · NVD
- FIRST EPSS
- GHSA-3fvg-4v2m-98jf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences