An XSS issue was discovered in MantisBT before 2.25.3.
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
An XSS issue was discovered in MantisBT before 2.25.3. Improper escaping of a Plugin name allows execution of arbitrary code (if CSP allows it) in manage_plugin_page.php and manage_plugin_uninstall.php when a crafted plugin is installed.
Why it matters now
EPSS 0.00835 57th percentileScored 2026-11-07
Fix Fixed mantisbt/mantisbt (Packagist): 2.25.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | mantisbt/mantisbt (Packagist) | before 2.25.3 | 2.25.3 | Patch available | GHSA-rqgj-rqfr-5j6f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- mantisbt/mantisbt (Packagist) Vendor— Affected before 2.25.3 Fixed in 2.25.3 Patch available GHSA-rqgj-rqfr-5j6f
Remediation
- Fix · GHSA-rqgj-rqfr-5j6f mantisbt/mantisbt (Packagist) Fixed in 2.25.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-26144
- 2026-10-03 Alias added: GHSA-rqgj-rqfr-5j6f
References
More Mantisbt vulnerabilities
- TI-2017-05251 MantisBT through 2.3.0 allows arbitrary password reset and unauthenticated admin access… CVSS 3.1HIGH 8.8
- TI-2014-05966 The XmlImportExport plugin in MantisBT 1.2.17 and earlier allows remote attackers to… CVSS 2.0HIGH 7.5
- TI-2025-38760 MantisBT unauthorized disclosure of private project column configuration CVSS 4.0MEDIUM 5.3
- TI-2017-04981 A cross-site scripting (XSS) vulnerability in the MantisBT Configuration Report page… CVSS 3.0MEDIUM 4.8
- TI-2019-11797 MantisBT before 1.3.20 and 2.22.1 allows Post Authentication Command Injection, leading to Remote Code Execution. CVSS 3.1HIGH 7.2
- TI-2014-07063 The XML Import/Export plugin in MantisBT 1.2.x does not restrict access, which allows… CVSS 2.0MEDIUM 6.4
Sources
- CVE-2022-26144 · CVE Program
- CVE-2022-26144 · NVD
- FIRST EPSS
- GHSA-rqgj-rqfr-5j6f · GitHub Advisory Database · CC BY 4.0
- CVE-2022-26144 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences