Weak Master Keys
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Partial Red Hat: 4 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and Red Hat. Impact type from CWE-326.
Summary
LibreOffice supports the storage of passwords for web connections in the user’s configuration database. The stored passwords are encrypted with a single master key provided by the user. A flaw in LibreOffice existed where master key was poorly encoded resulting in weakening its entropy from 128 to 43 bits making the stored passwords vulerable to a brute force attack if an attacker has access to the users stored config. This issue affects: The Document Foundation LibreOffice 7.2 versions prior to 7.2.7; 7.3 versions prior to 7.3.3.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| The Document Foundation | LibreOffice | 7.2 to before 7.2.7; 7.3 to before 7.3.3 | 7.2.7, 7.3.3 | Patch available | CNA |
- LibreOffice VendorThe Document Foundation Affected 7.2 to before 7.2.7; 7.3 to before 7.3.3 Fixed in 7.2.7, 7.3.3 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* | 7.2.0 to before 7.2.7; 7.3.0 to before 7.3.3 | Vulnerable | The Document Foundation |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
- cpe:2.3:a:libreoffice:libreoffice:*:*:*:*:*:*:*:* Versions 7.2.0 to before 7.2.7; 7.3.0 to before 7.3.3 Vulnerable ·The Document Foundation
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
Remediation
- Fix · CNA LibreOffice (The Document Foundation) Fixed in 7.2.7, 7.3.3
Red Hat 2 advisories
- RHSA-2023:0304 Released 2023-01-23 · Red Hat rating Moderatelibreoffice security update
- Red Hat CodeReady Linux Builder (v. 9) libreoffice-sdk-1:7.1.8.1-8.el9_1, libreoffice-sdk-doc-1:7.1.8.1-8.el9_1
- Red Hat Enterprise Linux AppStream (v. 9) autocorr-af-1:7.1.8.1-8.el9_1, autocorr-bg-1:7.1.8.1-8.el9_1, autocorr-ca-1:7.1.8.1-8.el9_1 +47
- RHSA-2023:0089 Released 2023-01-12 · Red Hat rating Moderatelibreoffice security update
- Red Hat CodeReady Linux Builder (v. 8) libreoffice-sdk-1:6.4.7.2-12.el8_7, libreoffice-sdk-doc-1:6.4.7.2-12.el8_7
- Red Hat Enterprise Linux AppStream (v. 8) autocorr-af-1:6.4.7.2-12.el8_7, autocorr-bg-1:6.4.7.2-12.el8_7, autocorr-ca-1:6.4.7.2-12.el8_7 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| Red Hat Enterprise Linux 8 | Affected | No fix planned: Will not fix |
| Red Hat Enterprise Linux 9 | Affected | No fix yet |
| Red Hat CodeReady Linux Builder (v. 8) | Fixed | RHSA-2023:0089 |
| Red Hat CodeReady Linux Builder (v. 9) | Fixed | RHSA-2023:0304 |
| Red Hat Enterprise Linux AppStream (v. 8) | Fixed | RHSA-2023:0089 |
| Red Hat Enterprise Linux AppStream (v. 9) | Fixed | RHSA-2023:0304 |
Not affected: 2 products
- Red Hat Enterprise Linux 6
- Red Hat Enterprise Linux 7
Timeline
- 2026-10-02 Threatist record created from CVE-2022-26307
- 2026-10-03 Alias added: GHSA-7p78-g262-f9rp
References
More The Document Foundation Libreoffice vulnerabilities
- TI-2019-07233 LibreLogo global-event script execution CVSS 3.1CRITICAL 9.8
- TI-2018-12068 Path traversal in [UNKNOWN] libreoffice CVSS 3.0CRITICAL 9.8
- TI-2018-07474 An information disclosure vulnerability occurs when LibreOffice 6.0.3 and Apache… CVSS 3.0HIGH 7.5
- TI-2019-07230 Code injection in Document Foundation LibreOffice CVSS 3.1CRITICAL 9.8
- TI-2018-05018 LibreOffice before 5.4.5 and 6.x before 6.0.1 allows remote attackers to read arbitrary… CVSS 3.0CRITICAL 9.8
- TI-2023-01118 Arbitrary file write in libreoffice CVSS 3.1MEDIUM 5.5
Sources
- CVE-2022-26307 · CVE Program
- CVE-2022-26307 · NVD
- FIRST EPSS
- GHSA-7p78-g262-f9rp · GitHub Advisory Database · CC BY 4.0
- CVE-2022-26307 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences