An issue was discovered in Asterisk through 19.x and Certified Asterisk through…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
An issue was discovered in Asterisk through 19.x and Certified Asterisk through 16.8-cert13. The func_odbc module provides possibly inadequate escaping functionality for backslash characters in SQL queries, resulting in user-provided data creating a broken SQL query or possibly a SQL injection. This is fixed in 16.25.2, 18.11.2, and 19.3.2, and 16.8-cert14.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 24
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:digium:asterisk:*:*:*:*:*:*:*:* | 16.0.0 to before 16.25.2; 18.0 to before 18.11.2; 19.0.0 to before 19.3.2 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:-:*:*:*:*:*:* | 16.8 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc1:*:*:*:*:*:* | 16.8 cert1-rc1 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc2:*:*:*:*:*:* | 16.8 cert1-rc2 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc3:*:*:*:*:*:* | 16.8 cert1-rc3 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc4:*:*:*:*:*:* | 16.8 cert1-rc4 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert10:*:*:*:*:*:* | 16.8 cert10 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert11:*:*:*:*:*:* | 16.8 cert11 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert12:*:*:*:*:*:* | 16.8 cert12 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert13:*:*:*:*:*:* | 16.8 cert13 | Vulnerable | Digium |
- cpe:2.3:a:digium:asterisk:*:*:*:*:*:*:*:* Versions 16.0.0 to before 16.25.2; 18.0 to before 18.11.2; 19.0.0 to before 19.3.2 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:-:*:*:*:*:*:* Versions 16.8 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc1:*:*:*:*:*:* Versions 16.8 cert1-rc1 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc2:*:*:*:*:*:* Versions 16.8 cert1-rc2 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc3:*:*:*:*:*:* Versions 16.8 cert1-rc3 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert1-rc4:*:*:*:*:*:* Versions 16.8 cert1-rc4 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert10:*:*:*:*:*:* Versions 16.8 cert10 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert11:*:*:*:*:*:* Versions 16.8 cert11 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert12:*:*:*:*:*:* Versions 16.8 cert12 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert13:*:*:*:*:*:* Versions 16.8 cert13 Vulnerable ·Digium
Show 14 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:digium:certified_asterisk:16.8:cert2:*:*:*:*:*:* | 16.8 cert2 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert3:*:*:*:*:*:* | 16.8 cert3 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert4:*:*:*:*:*:* | 16.8 cert4 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc1:*:*:*:*:*:* | 16.8 cert4-rc1 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc2:*:*:*:*:*:* | 16.8 cert4-rc2 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc3:*:*:*:*:*:* | 16.8 cert4-rc3 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc4:*:*:*:*:*:* | 16.8 cert4-rc4 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert5:*:*:*:*:*:* | 16.8 cert5 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert6:*:*:*:*:*:* | 16.8 cert6 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert7:*:*:*:*:*:* | 16.8 cert7 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert8:*:*:*:*:*:* | 16.8 cert8 | Vulnerable | Digium |
| cpe:2.3:a:digium:certified_asterisk:16.8:cert9:*:*:*:*:*:* | 16.8 cert9 | Vulnerable | Digium |
| cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* | 10.0 | Vulnerable | Debian |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:digium:certified_asterisk:16.8:cert2:*:*:*:*:*:* Versions 16.8 cert2 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert3:*:*:*:*:*:* Versions 16.8 cert3 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert4:*:*:*:*:*:* Versions 16.8 cert4 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc1:*:*:*:*:*:* Versions 16.8 cert4-rc1 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc2:*:*:*:*:*:* Versions 16.8 cert4-rc2 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc3:*:*:*:*:*:* Versions 16.8 cert4-rc3 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert4-rc4:*:*:*:*:*:* Versions 16.8 cert4-rc4 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert5:*:*:*:*:*:* Versions 16.8 cert5 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert6:*:*:*:*:*:* Versions 16.8 cert6 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert7:*:*:*:*:*:* Versions 16.8 cert7 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert8:*:*:*:*:*:* Versions 16.8 cert8 Vulnerable ·Digium
- cpe:2.3:a:digium:certified_asterisk:16.8:cert9:*:*:*:*:*:* Versions 16.8 cert9 Vulnerable ·Digium
- cpe:2.3:o:debian:debian_linux:10.0:*:*:*:*:*:*:* Versions 10.0 Vulnerable ·Debian
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
No fixed version listed by the sources yet.
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-26651
- 2026-10-03 Alias added: GHSA-6pcv-f66p-pqqj
References
Sources
- CVE-2022-26651 · CVE Program
- CVE-2022-26651 · NVD
- FIRST EPSS
- GHSA-6pcv-f66p-pqqj · GitHub Advisory Database · CC BY 4.0
- CVE-2022-26651 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences