Apple Security Update - Catalina: A malicious application may be able to modify protected…
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
This issue was addressed with improved entitlements. This issue is fixed in Security Update 2022-004 Catalina, macOS Monterey 12.4. A malicious application may be able to modify protected parts of the file system.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apple | Security Update - Catalina | before 2022 | 2022 | Patch available | CNA |
| Apple | macOS | before 12.4 | 12.4 | Patch available | CNA |
- Security Update - Catalina VendorApple Affected before 2022 Fixed in 2022 Patch available CNA
- macOS VendorApple Affected before 12.4 Fixed in 12.4 Patch available CNA
CPE configurations NVD · 15
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* | 10.15 to before 10.15.7 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:-:*:*:*:*:*:* | 10.15.7 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* | 10.15.7 security_update_2020-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-001:*:*:*:*:*:* | 10.15.7 security_update_2021-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-002:*:*:*:*:*:* | 10.15.7 security_update_2021-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-003:*:*:*:*:*:* | 10.15.7 security_update_2021-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-004:*:*:*:*:*:* | 10.15.7 security_update_2021-004 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-005:*:*:*:*:*:* | 10.15.7 security_update_2021-005 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-006:*:*:*:*:*:* | 10.15.7 security_update_2021-006 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-007:*:*:*:*:*:* | 10.15.7 security_update_2021-007 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:* Versions 10.15 to before 10.15.7 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:-:*:*:*:*:*:* Versions 10.15.7 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2020-001:*:*:*:*:*:* Versions 10.15.7 security_update_2020-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-001:*:*:*:*:*:* Versions 10.15.7 security_update_2021-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-002:*:*:*:*:*:* Versions 10.15.7 security_update_2021-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-003:*:*:*:*:*:* Versions 10.15.7 security_update_2021-003 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-004:*:*:*:*:*:* Versions 10.15.7 security_update_2021-004 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-005:*:*:*:*:*:* Versions 10.15.7 security_update_2021-005 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-006:*:*:*:*:*:* Versions 10.15.7 security_update_2021-006 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-007:*:*:*:*:*:* Versions 10.15.7 security_update_2021-007 Vulnerable ·Apple
Show 5 more CPE
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-008:*:*:*:*:*:* | 10.15.7 security_update_2021-008 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-001:*:*:*:*:*:* | 10.15.7 security_update_2022-001 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-002:*:*:*:*:*:* | 10.15.7 security_update_2022-002 | Vulnerable | Apple |
| cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-003:*:*:*:*:*:* | 10.15.7 security_update_2022-003 | Vulnerable | Apple |
| cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* | 12.0 to before 12.4 | Vulnerable | Apple |
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2021-008:*:*:*:*:*:* Versions 10.15.7 security_update_2021-008 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-001:*:*:*:*:*:* Versions 10.15.7 security_update_2022-001 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-002:*:*:*:*:*:* Versions 10.15.7 security_update_2022-002 Vulnerable ·Apple
- cpe:2.3:o:apple:mac_os_x:10.15.7:security_update_2022-003:*:*:*:*:*:* Versions 10.15.7 security_update_2022-003 Vulnerable ·Apple
- cpe:2.3:o:apple:macos:*:*:*:*:*:*:*:* Versions 12.0 to before 12.4 Vulnerable ·Apple
Remediation
- Fix · CNA Security Update - Catalina (Apple) Fixed in 2022
- Fix · CNA macOS (Apple) Fixed in 12.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
Apple macOS 12.4
36 records Highest priority Priority MEDIUM 7 MEDIUM, 29 LOW
Other records, highest priority first
- TI-2022-10025 Memory corruption in Apple macOSPriority MEDIUM 53
- TI-2022-10024 Integer overflow in Apple Security Update - CatalinaPriority MEDIUM 53
- TI-2022-09964 Apple macOS: An attacker may be able to cause unexpected application termination or…Priority MEDIUM 46
- Release ·
Apple Security Update - Catalina 2022
17 records Highest priority Priority MEDIUM 2 MEDIUM, 15 LOW
Other records, highest priority first
- TI-2022-10024 Integer overflow in Apple Security Update - CatalinaPriority MEDIUM 53
- TI-2022-09998 Out-of-bounds write in Apple Security Update - CatalinaPriority MEDIUM 41
- TI-2022-10019 Out-of-bounds read in Apple Security Update - CatalinaPriority LOW 38
Timeline
- 2026-10-02 Threatist record created from CVE-2022-26727
- 2026-10-03 Alias added: GHSA-j2hf-jfff-fhwj
References
More Apple Mac Os X vulnerabilities
- TI-2021-01573 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2021-01572 Apple iOS and iPadOS: A remote attacker may be able to cause arbitrary code execution KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05157 GNU Bash through 4.3 processes trailing strings after function definitions in the values… KEVCVSS 3.1CRITICAL 9.8
- TI-2012-01607 sapi/cgi/cgi_main.c in PHP before 5.3.12 and 5.4.x before 5.4.2, when configured as a CGI… KEVCVSS 3.1CRITICAL 9.8
- TI-2022-02117 Out-of-bounds write in Google Chrome KEVCVSS 3.1HIGH 8.8
Sources
- CVE-2022-26727 · CVE Program
- CVE-2022-26727 · NVD
- FIRST EPSS
- GHSA-j2hf-jfff-fhwj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences