Read the docs
TI-2022-10256 Aliases CVE-2022-27103GHSA-rjvg-8v36-xv9r

element-plus 2.0.5 is vulnerable to Cross Site Scripting (XSS) via el-table-column.

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.

Summary

element-plus 2.0.5 is vulnerable to Cross Site Scripting (XSS) via el-table-column.

Why it matters now

EPSS 0.00894 59th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed element-plus (npm): 2.0.6

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
——all versions—No fix listedCNA
—element-plus (npm)before 2.0.62.0.6Patch availableGHSA-rjvg-8v36-xv9r
  • — Vendor— Affected all versions Fixed in — No fix listed CNA
  • element-plus (npm) Vendor— Affected before 2.0.6 Fixed in 2.0.6 Patch available GHSA-rjvg-8v36-xv9r

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:element-plus:element-plus:2.0.5:*:*:*:*:*:*:*2.0.5VulnerableElement-plus
  • cpe:2.3:a:element-plus:element-plus:2.0.5:*:*:*:*:*:*:* Versions 2.0.5 Vulnerable ·Element-plus

Remediation

  • Fix · GHSA-rjvg-8v36-xv9r element-plus (npm) Fixed in 2.0.6 Advisory →

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-27103
  2. 2026-10-03 Alias added: GHSA-rjvg-8v36-xv9r

References

  • TI-2025-35599 Element Plus Link component (el-link) through 2.10.6 implements insufficient input… CVSS 3.1MEDIUM 6.4

Sources