CVRF-CSAF-Converter before 1.0.0-rc2 resolves XML External Entities (XXE).
Priority LOW 28CWE-611Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-552.
Summary
CVRF-CSAF-Converter before 1.0.0-rc2 resolves XML External Entities (XXE). This leads to the inclusion of arbitrary (local) file content into the generated output document. An attacker can exploit this to disclose information from the system running the converter.
Why it matters now
EPSS 0.00695 53rd percentileScored 2026-11-07
Fix Fixed cvrf2csaf (PyPI): 1.0.0rc2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | cvrf2csaf (PyPI) | before 1.0.0rc2 | 1.0.0rc2 | Patch available | GHSA-m8gq-83gh-v42v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- cvrf2csaf (PyPI) Vendor— Affected before 1.0.0rc2 Fixed in 1.0.0rc2 Patch available GHSA-m8gq-83gh-v42v
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:alpha:*:*:*:*:*:* | 1.0.0 alpha | Vulnerable | Cvrf-csaf-converter Project |
| cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:dev1:*:*:*:*:*:* | 1.0.0 dev1 | Vulnerable | Cvrf-csaf-converter Project |
| cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:dev2:*:*:*:*:*:* | 1.0.0 dev2 | Vulnerable | Cvrf-csaf-converter Project |
| cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:dev3:*:*:*:*:*:* | 1.0.0 dev3 | Vulnerable | Cvrf-csaf-converter Project |
| cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:rc1:*:*:*:*:*:* | 1.0.0 rc1 | Vulnerable | Cvrf-csaf-converter Project |
- cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:alpha:*:*:*:*:*:* Versions 1.0.0 alpha Vulnerable ·Cvrf-csaf-converter Project
- cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:dev1:*:*:*:*:*:* Versions 1.0.0 dev1 Vulnerable ·Cvrf-csaf-converter Project
- cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:dev2:*:*:*:*:*:* Versions 1.0.0 dev2 Vulnerable ·Cvrf-csaf-converter Project
- cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:dev3:*:*:*:*:*:* Versions 1.0.0 dev3 Vulnerable ·Cvrf-csaf-converter Project
- cpe:2.3:a:cvrf-csaf-converter_project:cvrf-csaf-converter:1.0.0:rc1:*:*:*:*:*:* Versions 1.0.0 rc1 Vulnerable ·Cvrf-csaf-converter Project
Remediation
- Fix · GHSA-m8gq-83gh-v42v cvrf2csaf (PyPI) Fixed in 1.0.0rc2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-27193
- 2026-10-03 Alias added: GHSA-m8gq-83gh-v42v
References
Sources
- CVE-2022-27193 · CVE Program
- CVE-2022-27193 · NVD
- FIRST EPSS
- GHSA-m8gq-83gh-v42v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences