Cross-site scripting in https://github.com/rails/rails
Priority LOW 31CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Partial Red Hat: 1 fixed, 2 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-79.
Summary
A XSS Vulnerability in Action View tag helpers >= 5.2.0 and < 5.2.0 which would allow an attacker to inject content if able to control input into specific attributes.
Why it matters now
EPSS 0.01665 76th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial actionview (RubyGems): 5.2.7.1, 6.0.4.8, 6.1.5.1 +1Red Hat: 1 advisoryRed Hat: 1 fixed, 2 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | https://github.com/rails/rails | 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1 | — | No fix listed | CNA |
| — | actionview (RubyGems) | before 5.2.7.1 | 5.2.7.1 | Patch available | GHSA-ch3h-j2vf-95pv |
| — | actionview (RubyGems) | 6.0.0 to before 6.0.4.8 | 6.0.4.8 | Patch available | GHSA-ch3h-j2vf-95pv |
| — | actionview (RubyGems) | 6.1.0 to before 6.1.5.1 | 6.1.5.1 | Patch available | GHSA-ch3h-j2vf-95pv |
| — | actionview (RubyGems) | 7.0.0 to before 7.0.2.4 | 7.0.2.4 | Patch available | GHSA-ch3h-j2vf-95pv |
- https://github.com/rails/rails Vendor— Affected 7.0.2.4, 6.1.5.1, 6.0.4.8, 5.2.7.1 Fixed in — No fix listed CNA
- actionview (RubyGems) Vendor— Affected before 5.2.7.1 Fixed in 5.2.7.1 Patch available GHSA-ch3h-j2vf-95pv
- actionview (RubyGems) Vendor— Affected 6.0.0 to before 6.0.4.8 Fixed in 6.0.4.8 Patch available GHSA-ch3h-j2vf-95pv
- actionview (RubyGems) Vendor— Affected 6.1.0 to before 6.1.5.1 Fixed in 6.1.5.1 Patch available GHSA-ch3h-j2vf-95pv
- actionview (RubyGems) Vendor— Affected 7.0.0 to before 7.0.2.4 Fixed in 7.0.2.4 Patch available GHSA-ch3h-j2vf-95pv
Remediation
- Fix · GHSA-ch3h-j2vf-95pv actionview (RubyGems) Fixed in 5.2.7.1 Advisory →
- Fix · GHSA-ch3h-j2vf-95pv actionview (RubyGems) Fixed in 6.0.4.8 Advisory →
- Fix · GHSA-ch3h-j2vf-95pv actionview (RubyGems) Fixed in 6.1.5.1 Advisory →
- Fix · GHSA-ch3h-j2vf-95pv actionview (RubyGems) Fixed in 7.0.2.4 Advisory →
Red Hat 1 advisory
- RHSA-2023:2097 Released 2023-05-03 · Red Hat rating ImportantSatellite 6.13 Release
- Red Hat Satellite 6.13 for RHEL 8 ansible-collection-redhat-satellite-3.9.0-2.el8sat, ansible-collection-redhat-satellite_operations-1.3.0-2.el8sat, ansible-lint-5.0.8-4.el8pc +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| CloudForms Management Engine 5 | Affected | No fix planned: Out of support scope |
| Red Hat 3scale API Management Platform 2 | Affected | No fix planned: Will not fix |
| Red Hat Satellite 6.13 for RHEL 8 | Fixed | RHSA-2023:2097 |
Not affected: 1 product
- Red Hat Satellite 6.13 for RHEL 8
Timeline
- 2026-10-02 Threatist record created from CVE-2022-27777
- 2026-10-03 Alias added: GHSA-ch3h-j2vf-95pv
References
Advisory 3
Other 5
- https://github.com/rails/rails/commit/649516ce0feb699ae06a8c5e81df75d460cc9a85
- https://github.com/rails/rails
- https://github.com/rubysec/ruby-advisory-db/blob/master/gems/actionview/CVE-2022-27777.yml
- https://groups.google.com/g/ruby-security-ann/c/9wJPEDv-iRw
- https://rubyonrails.org/2022/4/26/Rails-7-0-2-4-6-1-5-1-6-0-4-8-and-5-2-7-1-have-been-released
Sources
- CVE-2022-27777 · CVE Program
- CVE-2022-27777 · NVD
- FIRST EPSS
- GHSA-ch3h-j2vf-95pv · GitHub Advisory Database · CC BY 4.0
- CVE-2022-27777 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences