Missing authorization in Jenkins Bitbucket Server Integration Plugin
Priority LOW 26CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-862.
Summary
Jenkins Bitbucket Server Integration Plugin 3.1.0 and earlier does not perform permission checks in several HTTP endpoints, allowing attackers with Overall/Read permission to create, view, and delete BitBucket Server consumers.
Why it matters now
EPSS 0.00668 52nd percentileScored 2026-11-07
Fix Fixed io.jenkins.plugins:atlassian-bitbucket-server-integration (Maven): 3.2.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins Bitbucket Server Integration Plugin | up to 3.1.0 | — | No fix listed | CNA |
| — | io.jenkins.plugins:atlassian-bitbucket-server-integration (Maven) | before 3.2.0 | 3.2.0 | Patch available | GHSA-r5r6-v8qh-pmpq |
- Jenkins Bitbucket Server Integration Plugin VendorJenkins Affected up to 3.1.0 Fixed in — No fix listed CNA
- io.jenkins.plugins:atlassian-bitbucket-server-integration (Maven) Vendor— Affected before 3.2.0 Fixed in 3.2.0 Patch available GHSA-r5r6-v8qh-pmpq
Remediation
- Fix · GHSA-r5r6-v8qh-pmpq io.jenkins.plugins:atlassian-bitbucket-server-integration (Maven) Fixed in 3.2.0 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-28134
- 2026-10-03 Alias added: GHSA-r5r6-v8qh-pmpq
References
More Jenkins Bitbucket Server Integration vulnerabilities
- TI-2025-18135 Cross-site request forgery in Jenkins Bitbucket Server Integration Plugin CVSS 3.1HIGH 8.8
- TI-2022-10931 Cross-site scripting in Jenkins Bitbucket Server Integration Plugin CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-28134 · CVE Program
- CVE-2022-28134 · NVD
- FIRST EPSS
- GHSA-r5r6-v8qh-pmpq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences