Certain Neko-related HTML parsers allow a denial of service via crafted Processing…
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · None · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Certain Neko-related HTML parsers allow a denial of service via crafted Processing Instruction (PI) input that causes excessive heap memory consumption. In particular, this issue exists in HtmlUnit-Neko through 2.26, and is fixed in 2.27. This issue also exists in CyberNeko HTML through 1.9.22 (also affecting OWASP AntiSamy before 1.6.6), but 1.9.22 is the last version of CyberNeko HTML. NOTE: this may be related to CVE-2022-24839.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | net.sourceforge.htmlunit:neko-htmlunit (Maven) | before 2.27 | 2.27 | Patch available | GHSA-g9hh-vvx3-v37v |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- net.sourceforge.htmlunit:neko-htmlunit (Maven) Vendor— Affected before 2.27 Fixed in 2.27 Patch available GHSA-g9hh-vvx3-v37v
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cyberneko_html_project:cyberneko_html:*:*:*:*:*:*:*:* | up to 1.9.22 | Vulnerable | Cyberneko Html Project |
| cpe:2.3:a:htmlunit:htmlunit:*:*:*:*:*:*:*:* | before 2.27 | Vulnerable | HtmlUnit |
| cpe:2.3:a:antisamy_project:antisamy:*:*:*:*:*:*:*:* | before 1.6.6 | Vulnerable | Antisamy Project |
- cpe:2.3:a:cyberneko_html_project:cyberneko_html:*:*:*:*:*:*:*:* Versions up to 1.9.22 Vulnerable ·Cyberneko Html Project
- cpe:2.3:a:htmlunit:htmlunit:*:*:*:*:*:*:*:* Versions before 2.27 Vulnerable ·HtmlUnit
- cpe:2.3:a:antisamy_project:antisamy:*:*:*:*:*:*:*:* Versions before 1.6.6 Vulnerable ·Antisamy Project
Remediation
- Fix · GHSA-g9hh-vvx3-v37v net.sourceforge.htmlunit:neko-htmlunit (Maven) Fixed in 2.27 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-28366
- 2026-10-03 Alias added: GHSA-g9hh-vvx3-v37v
References
Advisory 4
Sources
- CVE-2022-28366 · CVE Program
- CVE-2022-28366 · NVD
- FIRST EPSS
- GHSA-g9hh-vvx3-v37v · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences