Broken or risky cryptographic algorithm in HPE StoreOnce Software
Priority LOW 34CWE-327Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-327.
Summary
A potential security vulnerability has been identified in HPE StoreOnce Software. The SSH server supports weak key exchange algorithms which could lead to remote unauthorized access. HPE has made the following software update to resolve the vulnerability in HPE StoreOnce Software 4.3.2.
Why it matters now
EPSS 0.00815 57th percentileScored 2026-11-07
Fix Fixed HPE StoreOnce Software: 4.3.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | HPE StoreOnce Software | before 4.3.2 | 4.3.2 | Patch available | CNA |
- HPE StoreOnce Software Vendor— Affected before 4.3.2 Fixed in 4.3.2 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:o:hpe:storeonce_3640_firmware:*:*:*:*:*:*:*:* | before 4.3.2 | Vulnerable | Hewlett Packard Enterprise (HPE) |
| cpe:2.3:h:hpe:storeonce_3640:-:*:*:*:*:*:*:* | not specified by NVD | Running on | Hewlett Packard Enterprise (HPE) |
- cpe:2.3:o:hpe:storeonce_3640_firmware:*:*:*:*:*:*:*:* Versions before 4.3.2 Vulnerable ·Hewlett Packard Enterprise (HPE)
- cpe:2.3:h:hpe:storeonce_3640:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·Hewlett Packard Enterprise (HPE)
Remediation
- Fix · CNA HPE StoreOnce Software Fixed in 4.3.2
Timeline
- 2026-10-02 Threatist record created from CVE-2022-28622
- 2026-10-03 Alias added: GHSA-6hj7-83x8-pjqq
References
More Hewlett Packard Enterprise (HPE) Storeonce 3640 Firmware vulnerabilities
- TI-2021-08310 Cross-site scripting in HPE StoreOnce 3620; HPE StoreOnce 3640; HPE StoreOnce 5200; HPE… CVSS 3.1MEDIUM 6.5
Sources
- CVE-2022-28622 · CVE Program
- CVE-2022-28622 · NVD
- FIRST EPSS
- GHSA-6hj7-83x8-pjqq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences