Cross-site scripting in F5 BIG-IP
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
On 16.1.x versions prior to 16.1.2.2, 15.1.x versions prior to 15.1.5.1, 14.1.x versions prior to 14.1.4.6, 13.1.x versions prior to 13.1.5, and all versions of 12.1.x 11.6.x, a DOM-based cross-site scripting (XSS) vulnerability exists in an undisclosed page of the BIG-IP AFM, CGNAT, and PEM Configuration utility that allows an attacker to execute JavaScript in the context of the currently logged-in user. Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| F5 | BIG-IP | 12.1.x; 11.6.x; 16.1.x to before 16.1.2.2; 15.1.x to before 15.1.5.1; 14.1.x to before 14.1.4.6; 13.1.x to before 13.1.5 | 17.0.0, 16.1.2.2, 15.1.5.1, 14.1.4.6, 13.1.5 | Patch available | CNA |
- BIG-IP VendorF5 Affected 12.1.x; 11.6.x; 16.1.x to before 16.1.2.2; 15.1.x to before 15.1.5.1; 14.1.x to before 14.1.4.6; 13.1.x to before 13.1.5 Fixed in 17.0.0, 16.1.2.2, 15.1.5.1, 14.1.4.6, 13.1.5 Patch available CNA
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:f5:big-ip_advanced_firewall_manager:*:*:*:*:*:*:*:* | 11.6.1 – 11.6.5; 12.1.0 – 12.1.6; 13.1.0 to before 13.1.5; 14.1.0 to before 14.1.4.6; 15.1.0 to before 15.1.5.1; 16.1.0 to before 16.1.2.2 | Vulnerable | F5 |
| cpe:2.3:a:f5:big-ip_carrier-grade_nat:*:*:*:*:*:*:*:* | 11.6.1 – 11.6.5; 12.1.0 – 12.1.6; 13.1.0 to before 13.1.5; 14.1.0 to before 14.1.4.6; 15.1.0 to before 15.1.5.1; 16.1.0 to before 16.1.2.2 | Vulnerable | F5 |
| cpe:2.3:a:f5:big-ip_policy_enforcement_manager:*:*:*:*:*:*:*:* | 11.6.1 – 11.6.5; 12.1.0 – 12.1.6; 13.1.0 to before 13.1.5; 14.1.0 to before 14.1.4.6; 15.1.0 to before 15.1.5.1; 16.1.0 to before 16.1.2.2 | Vulnerable | F5 |
- cpe:2.3:a:f5:big-ip_advanced_firewall_manager:*:*:*:*:*:*:*:* Versions 11.6.1 – 11.6.5; 12.1.0 – 12.1.6; 13.1.0 to before 13.1.5; 14.1.0 to before 14.1.4.6; 15.1.0 to before 15.1.5.1; 16.1.0 to before 16.1.2.2 Vulnerable ·F5
- cpe:2.3:a:f5:big-ip_carrier-grade_nat:*:*:*:*:*:*:*:* Versions 11.6.1 – 11.6.5; 12.1.0 – 12.1.6; 13.1.0 to before 13.1.5; 14.1.0 to before 14.1.4.6; 15.1.0 to before 15.1.5.1; 16.1.0 to before 16.1.2.2 Vulnerable ·F5
- cpe:2.3:a:f5:big-ip_policy_enforcement_manager:*:*:*:*:*:*:*:* Versions 11.6.1 – 11.6.5; 12.1.0 – 12.1.6; 13.1.0 to before 13.1.5; 14.1.0 to before 14.1.4.6; 15.1.0 to before 15.1.5.1; 16.1.0 to before 16.1.2.2 Vulnerable ·F5
Remediation
- Fix · CNA BIG-IP (F5) Fixed in 17.0.0, 16.1.2.2, 15.1.5.1, 14.1.4.6, 13.1.5
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
F5 BIG-IP 13.1.5, 14.1.4.6 and 3 more versions
10 records Highest priority Priority CRITICAL 1 CRITICAL, 1 MEDIUM, 8 LOW
Other records, highest priority first
- TI-2022-01269 Missing authentication in F5 BIG-IPPriority CRITICAL 100
- TI-2022-09767 Command injection in F5 BIG-IPPriority MEDIUM 41
- TI-2022-11347 Integer overflow in F5 BIG-IPPriority LOW 35
Timeline
- 2026-10-02 Threatist record created from CVE-2022-28716
- 2026-10-03 Alias added: GHSA-585h-3q27-j2jp
References
More F5 Big-ip Advanced Firewall Manager vulnerabilities
- TI-2023-25230 BIG-IP Configuration utility unauthenticated remote code execution vulnerability KEVCVSS 3.1CRITICAL 9.8
- TI-2022-01269 Missing authentication in F5 BIG-IP KEVCVSS 3.1CRITICAL 9.8
- TI-2021-05850 Memory corruption in BIG-IP KEVCVSS 3.1CRITICAL 9.8
- TI-2021-05845 Server-side request forgery in BIG-IP; BIG-IQ KEVCVSS 3.1CRITICAL 9.8
- TI-2020-04820 Path traversal in BIG-IP KEVCVSS 3.1CRITICAL 9.8
- TI-2014-05975 GNU Bash through 4.3 bash43-025 processes trailing strings after certain malformed… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2022-28716 · CVE Program
- CVE-2022-28716 · NVD
- FIRST EPSS
- GHSA-585h-3q27-j2jp · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences