Cross-site scripting in Jenkins promoted builds Plugin
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Jenkins promoted builds Plugin 873.v6149db_d64130 and earlier, except 3.10.1, does not escape the name and description of Promoted Build parameters on views displaying parameters, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers with Item/Configure permission.
Why it matters now
EPSS 0.00813 57th percentileScored 2026-11-07
Fix Fixed Jenkins promoted builds Plugin (Jenkins project): 3.10.1org.jenkins-ci.plugins:promoted-builds (Maven): 3.10.1, 876.v99d29788b
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Jenkins | Jenkins promoted builds Plugin | up to 873.v6149db_d64130 | 3.10.1 | Patch available | CNA |
| — | org.jenkins-ci.plugins:promoted-builds (Maven) | before 3.10.1 | 3.10.1 | Patch available | GHSA-v98r-gjgc-m9pf |
| — | org.jenkins-ci.plugins:promoted-builds (Maven) | 3.11 to before 876.v99d29788b | 876.v99d29788b | Patch available | GHSA-v98r-gjgc-m9pf |
- Jenkins promoted builds Plugin VendorJenkins Affected up to 873.v6149db_d64130 Fixed in 3.10.1 Patch available CNA
- org.jenkins-ci.plugins:promoted-builds (Maven) Vendor— Affected before 3.10.1 Fixed in 3.10.1 Patch available GHSA-v98r-gjgc-m9pf
- org.jenkins-ci.plugins:promoted-builds (Maven) Vendor— Affected 3.11 to before 876.v99d29788b Fixed in 876.v99d29788b Patch available GHSA-v98r-gjgc-m9pf
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:jenkins:promoted_builds:*:*:*:*:*:jenkins:*:* | before 3.10.1; 867.v7c3a_b_83a_eb_79 to before 876.v99d29788b_36b_ | Vulnerable | Jenkins |
- cpe:2.3:a:jenkins:promoted_builds:*:*:*:*:*:jenkins:*:* Versions before 3.10.1; 867.v7c3a_b_83a_eb_79 to before 876.v99d29788b_36b_ Vulnerable ·Jenkins
Remediation
- Fix · CNA Jenkins promoted builds Plugin (Jenkins project) Fixed in 3.10.1
- Fix · GHSA-v98r-gjgc-m9pf org.jenkins-ci.plugins:promoted-builds (Maven) Fixed in 3.10.1 Advisory →
- Fix · GHSA-v98r-gjgc-m9pf org.jenkins-ci.plugins:promoted-builds (Maven) Fixed in 876.v99d29788b Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29045
- 2026-10-03 Alias added: GHSA-v98r-gjgc-m9pf
References
More Jenkins Promoted Builds vulnerabilities
- TI-2022-13021 Cross-site scripting in Jenkins Promoted Builds Plugin CVSS 3.1MEDIUM 5.4
- TI-2022-11615 Cross-site scripting in Jenkins promoted builds Plugin CVSS 3.1MEDIUM 5.4
- TI-2021-04721 Cross-site request forgery in Jenkins promoted builds Plugin CVSS 3.1MEDIUM 4.3
- TI-2018-15767 An improper authorization vulnerability exists in Jenkins Promoted Builds Plugin 2.31.1… CVSS 3.0MEDIUM 4.3
Sources
- CVE-2022-29045 · CVE Program
- CVE-2022-29045 · NVD
- FIRST EPSS
- GHSA-v98r-gjgc-m9pf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences