URL Redirection to Untrusted Site ('Open Redirect') in next-auth
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Spoofing
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-601.
Summary
NextAuth.js (next-auth) is am open source authentication solution for Next.js applications. Prior to versions 3.29.3 and 4.3.3, an open redirect vulnerability is present when the developer is implementing an OAuth 1 provider. Versions 3.29.3 and 4.3.3 contain a patch for this issue. The maintainers recommend adding a certain configuration to one's `callbacks` option as a workaround for those unable to upgrade.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| nextauthjs | next-auth | before 3.29.3; 4.0.0 to before 4.3.3 | 3.29.3, 4.3.3 | Patch available | CNA |
| — | next-auth (npm) | before 3.29.3 | 3.29.3 | Patch available | GHSA-q2mx-j4x2-2h74 |
| — | next-auth (npm) | 4.0.0 to before 4.3.3 | 4.3.3 | Patch available | GHSA-q2mx-j4x2-2h74 |
- next-auth Vendornextauthjs Affected before 3.29.3; 4.0.0 to before 4.3.3 Fixed in 3.29.3, 4.3.3 Patch available CNA
- next-auth (npm) Vendor— Affected before 3.29.3 Fixed in 3.29.3 Patch available GHSA-q2mx-j4x2-2h74
- next-auth (npm) Vendor— Affected 4.0.0 to before 4.3.3 Fixed in 4.3.3 Patch available GHSA-q2mx-j4x2-2h74
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:nextauth.js:next-auth:*:*:*:*:*:node.js:*:* | before 3.29.3; 4.0.0 to before 4.3.3 | Vulnerable | nextauthjs |
- cpe:2.3:a:nextauth.js:next-auth:*:*:*:*:*:node.js:*:* Versions before 3.29.3; 4.0.0 to before 4.3.3 Vulnerable ·nextauthjs
Remediation
- Fix · CNA next-auth (nextauthjs) Fixed in 3.29.3, 4.3.3
- Fix · GHSA-q2mx-j4x2-2h74 next-auth (npm) Fixed in 3.29.3 Advisory →
- Fix · GHSA-q2mx-j4x2-2h74 next-auth (npm) Fixed in 4.3.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29214
- 2026-10-03 Alias added: GHSA-q2mx-j4x2-2h74
- 2026-10-08 EPSS moved to the 50th–90th percentile
References
More nextauthjs Next-auth vulnerabilities
- TI-2022-13171 Improper handling of email input in next-auth CVSS 3.1HIGH 7.1
- TI-2022-16351 Verification requests (magic link) sent to unwanted emails CVSS 3.1CRITICAL 9.1
- TI-2022-13137 Improper Handling of `callbackUrl` parameter in next-auth CVSS 3.1HIGH 7.5
- TI-2023-12218 Missing proper state, nonce and PKCE checks for OAuth authentication in next-auth CVSS 3.1HIGH 8.8
- TI-2022-18639 NextAuth.js Upstash Adapter missing token verification CVSS 3.1HIGH 8.1
- TI-2023-26172 next-auth vulnerable to possible user mocking that bypasses basic authentication CVSS 3.1MEDIUM 5.3
Sources
- CVE-2022-29214 · CVE Program
- CVE-2022-29214 · NVD
- FIRST EPSS
- GHSA-q2mx-j4x2-2h74 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences