Potential cross-site scripting (XSS) vulnerability in Hydrogen
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · Low
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Hydrogen is a React-based framework for building dynamic, Shopify-powered custom storefronts. There is a potential Cross-Site Scripting (XSS) vulnerability where an arbitrary user is able to execute scripts on pages that are built with Hydrogen. This affects all versions of Hydrogen starting from version 0.10.0 to 0.18.0. This vulnerability is exploitable in applications whose hydrating data is user controlled. All Hydrogen users should upgrade their project to version 0.19.0. There is no current workaround, and users should update as soon as possible. Additionally, the Content Security Policy is not an effective mitigation for this vulnerability.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| remix-run | hydrogen | 0.10.0 – 0.18.0 | — | No fix listed | CNA |
| — | @shopify/hydrogen (npm) | 0.10.0 to before 0.19.0 | 0.19.0 | Patch available | GHSA-6j22-wv8g-894f |
- hydrogen Vendorremix-run Affected 0.10.0 – 0.18.0 Fixed in — No fix listed CNA
- @shopify/hydrogen (npm) Vendor— Affected 0.10.0 to before 0.19.0 Fixed in 0.19.0 Patch available GHSA-6j22-wv8g-894f
Remediation
- Fix · GHSA-6j22-wv8g-894f @shopify/hydrogen (npm) Fixed in 0.19.0 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29230
- 2026-10-03 Alias added: GHSA-6j22-wv8g-894f
References
Patch 2
Advisory 2
Sources
- CVE-2022-29230 · CVE Program
- CVE-2022-29230 · NVD
- FIRST EPSS
- GHSA-6j22-wv8g-894f · GitHub Advisory Database · CC BY 4.0
- CVE-2022-29230 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences