Read the docs
TI-2022-11785 Aliases CVE-2022-29244GHSA-hj9c-8jmm-8c52

npm packing does not respect root-level ignore files in workspaces

Priority MEDIUM 46CWE-200Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Information disclosure
Confidentiality · integrity · availability
High · None · None
Fix status
Partial Red Hat: 1 fixed, 1 without a fix

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-200.

Summary

npm pack ignores root-level .gitignore and .npmignore file exclusion directives when run in a workspace or with a workspace flag (ie. `--workspaces`, `--workspace=<name>`). Anyone who has run `npm pack` or `npm publish` inside a workspace, as of v7.9.0 and v7.13.0 respectively, may be affected and have published files into the npm registry they did not intend to include. Users should upgrade to the latest, patched version of npm v8.11.0, run: npm i -g npm@latest . Node.js versions v16.15.1, v17.19.1, and v18.3.0 include the patched v8.11.0 version of npm.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.04004 90th percentileScored 2026-11-07
Fix Partial npm (npm): 8.11.0Red Hat: 1 advisoryRed Hat: 1 fixed, 1 without a fix

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
Yes
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
npmnpm7.9.0 and later; 8.11.0 to before 8.11.08.11.0Patch availableCNA
—npm (npm)7.9.0 to before 8.11.08.11.0Patch availableGHSA-hj9c-8jmm-8c52
  • npm Vendornpm Affected 7.9.0 and later; 8.11.0 to before 8.11.0 Fixed in 8.11.0 Patch available CNA
  • npm (npm) Vendor— Affected 7.9.0 to before 8.11.0 Fixed in 8.11.0 Patch available GHSA-hj9c-8jmm-8c52

CPE configurations NVD · 2

CPEVersionsRoleVendor
cpe:2.3:a:npmjs:npm:*:*:*:*:*:*:*:*7.9.0 to before 8.11.0VulnerableNpmjs
cpe:2.3:a:netapp:ontap_select_deploy_administration_utility:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
  • cpe:2.3:a:npmjs:npm:*:*:*:*:*:*:*:* Versions 7.9.0 to before 8.11.0 Vulnerable ·Npmjs
  • cpe:2.3:a:netapp:ontap_select_deploy_administration_utility:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp

Remediation

  • Fix · CNA npm (npm) Fixed in 8.11.0
  • Fix · GHSA-hj9c-8jmm-8c52 npm (npm) Fixed in 8.11.0 Advisory →

Red Hat 1 advisory

  • RHSA-2022:6595 Released 2022-09-20 · Red Hat rating Moderate
    nodejs and nodejs-nodemon security and bug fix update
    • Red Hat Enterprise Linux AppStream (v. 9) nodejs-1:16.16.0-1.el9_0, nodejs-docs-1:16.16.0-1.el9_0, nodejs-full-i18n-1:16.16.0-1.el9_0 +3

Vendor assessments

Red Hat

Red Hat rating: Moderate. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat Enterprise Linux 8AffectedNo fix yet
Red Hat Enterprise Linux AppStream (v. 9)Fixed RHSA-2022:6595
Not affected: 3 products
  • Red Hat Enterprise Linux 8
  • Red Hat Enterprise Linux AppStream (v. 9)
  • Red Hat Software Collections

Timeline

  1. 2026-10-02 Threatist record created from CVE-2022-29244
  2. 2026-10-03 Alias added: GHSA-hj9c-8jmm-8c52
  3. 2026-10-07 EPSS moved to the 90th–95th percentile

References

Sources