Cross-domain cookie leakage in Guzzle
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- High · High · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-200.
Summary
Guzzle is a PHP HTTP client. Guzzle prior to versions 6.5.6 and 7.4.3 contains a vulnerability with the cookie middleware. The vulnerability is that it is not checked if the cookie domain equals the domain of the server which sets the cookie via the Set-Cookie header, allowing a malicious server to set cookies for unrelated domains. The cookie middleware is disabled by default, so most library consumers will not be affected by this issue. Only those who manually add the cookie middleware to the handler stack or construct the client with ['cookies' => true] are affected. Moreover, those who do not use the same Guzzle client to call multiple domains and have disabled redirect forwarding are not affected by this vulnerability. Guzzle versions 6.5.6 and 7.4.3 contain a patch for this issue. As a workaround, turn off the cookie middleware.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- None
- Automatable
- No
- Technical impact
- Total
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| guzzle | guzzle | before 6.5.6; 7.0.0 to before 7.4.3 | 6.5.6, 7.4.3 | Patch available | CNA |
| — | guzzlehttp/guzzle (Packagist) | before 6.5.6 | 6.5.6 | Patch available | GHSA-cwmx-hcrq-mhc3 |
| — | guzzlehttp/guzzle (Packagist) | 7.0.0 to before 7.4.3 | 7.4.3 | Patch available | GHSA-cwmx-hcrq-mhc3 |
- guzzle Vendorguzzle Affected before 6.5.6; 7.0.0 to before 7.4.3 Fixed in 6.5.6, 7.4.3 Patch available CNA
- guzzlehttp/guzzle (Packagist) Vendor— Affected before 6.5.6 Fixed in 6.5.6 Patch available GHSA-cwmx-hcrq-mhc3
- guzzlehttp/guzzle (Packagist) Vendor— Affected 7.0.0 to before 7.4.3 Fixed in 7.4.3 Patch available GHSA-cwmx-hcrq-mhc3
CPE configurations NVD · 3
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:guzzlephp:guzzle:*:*:*:*:*:*:*:* | before 6.5.6; 7.0.0 to before 7.4.3 | Vulnerable | guzzle |
| cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* | 9.2.0 to before 9.2.20; 9.3.0 to before 9.3.14 | Vulnerable | Drupal |
| cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* | 11.0 | Vulnerable | Debian |
- cpe:2.3:a:guzzlephp:guzzle:*:*:*:*:*:*:*:* Versions before 6.5.6; 7.0.0 to before 7.4.3 Vulnerable ·guzzle
- cpe:2.3:a:drupal:drupal:*:*:*:*:*:*:*:* Versions 9.2.0 to before 9.2.20; 9.3.0 to before 9.3.14 Vulnerable ·Drupal
- cpe:2.3:o:debian:debian_linux:11.0:*:*:*:*:*:*:* Versions 11.0 Vulnerable ·Debian
Remediation
- Fix · CNA guzzle (guzzle) Fixed in 6.5.6, 7.4.3
- Fix · GHSA-cwmx-hcrq-mhc3 guzzlehttp/guzzle (Packagist) Fixed in 6.5.6 Advisory →
- Fix · GHSA-cwmx-hcrq-mhc3 guzzlehttp/guzzle (Packagist) Fixed in 7.4.3 Advisory →
Vendor assessments
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29248
- 2026-10-03 Alias added: GHSA-cwmx-hcrq-mhc3
References
Patch 3
Advisory 3
More Guzzle vulnerabilities
- TI-2022-13088 Fix failure to strip Authorization header on HTTP downgrade in Guzzle CVSS 3.1HIGH 7.5
- TI-2022-13087 Failure to strip the Cookie header on change in host or HTTP downgrade in Guzzle CVSS 3.1HIGH 7.5
- TI-2022-13135 Change in port should be considered a change in origin in Guzzle CVSS 3.1HIGH 7.7
- TI-2022-13134 CURLOPT_HTTPAUTH option not cleared on change of origin in Guzzle CVSS 3.1HIGH 7.7
- TI-2026-40256 Guzzle: Dot-Only Cookie Domains Match All Hosts in guzzlehttp/guzzle CVSS 3.1MEDIUM 5.8
- TI-2026-42697 Guzzle: Cookie Disclosure and Injection via IP-Address Domains CVSS 3.1MEDIUM 6.1
Sources
- CVE-2022-29248 · CVE Program
- CVE-2022-29248 · NVD
- FIRST EPSS
- GHSA-cwmx-hcrq-mhc3 · GitHub Advisory Database · CC BY 4.0
- CVE-2022-29248 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences