Silverstripe silverstripe/assets through 1.10 is vulnerable to improper access control…
Priority LOW 23CWE-287Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-287.
Summary
Silverstripe silverstripe/assets through 1.10 is vulnerable to improper access control that allows protected images to be published by changing an existing image short code on website content.
Why it matters now
EPSS 0.01245 69th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed silverstripe/assets (Packagist): 1.10.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | silverstripe/assets (Packagist) | 1.0.0 to before 1.10.1 | 1.10.1 | Patch available | GHSA-v68g-62v9-39w5 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- silverstripe/assets (Packagist) Vendor— Affected 1.0.0 to before 1.10.1 Fixed in 1.10.1 Patch available GHSA-v68g-62v9-39w5
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:silverstripe:assets:*:*:*:*:*:*:*:* | before 1.10.1 | Vulnerable | silverstripe |
- cpe:2.3:a:silverstripe:assets:*:*:*:*:*:*:*:* Versions before 1.10.1 Vulnerable ·silverstripe
Remediation
- Fix · GHSA-v68g-62v9-39w5 silverstripe/assets (Packagist) Fixed in 1.10.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-29858
- 2026-10-03 Alias added: GHSA-v68g-62v9-39w5
References
Patch 1
Advisory 5
More silverstripe Assets vulnerabilities
- TI-2022-18248 Silverstripe silverstripe/framework through 4.11.0, silverstripe/assets through 1.11.0… CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-29858 · CVE Program
- CVE-2022-29858 · NVD
- FIRST EPSS
- GHSA-v68g-62v9-39w5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences